BAR0 is 0M @ 0x0 (PCI:0000:01:00.0)

Hi! I’m new on this forum.

I’ve been struggling recently when trying to work my external monitor on different Linux distros. At first I installed Ubuntu, then Pop! OS and now Linux Mint. I wasn’t able to make it work on any distro. I know it’s not a GPU issue since on Windows works perfectly. In addition, Linux Mint seems to recognize the card and suggests installing the proper Nvidia drivers. I have installed the 525 version of it. On the kernel log (i think) this message is repeated several times:

nvidia-nvlink: Nvlink Core is being initialized, major device number 508
NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
NVRM: BAR0 is 0M @ 0x0 (PCI:0000:01:00.0)
nvidia: probe of 0000:01:00.0 failed with error -1
NVRM: The NVIDIA probe routine failed for 1 device(s).
NVRM: None of the NVIDIA devices were initialized.

I’m using a MSI GF65 Thin 10UE laptop with the RTX 3060M Nvidia graphics card.

This is the file:

nvidia-bug-report.log.gz (765.9 KB)

This is the dsmeg.log:

dmesg.log (263.4 KB)

Any help will be greatly appreciated. Thanks.

[ 0.411979] pci_bus 0000:00: Some PCI device resources are unassigned, try booting with pci=realloc

Did you try that?

Yes, but it didn’t change anything.

As the kernel seems to have problems configuring the hardware, I’d try a BIOS update:

BIOS Information
Vendor: American Megatrends Inc.
Version: E16W2IMS.103
Release Date: 01/08/2021

Is quite old.

I just installed the E16W2IMS.105 version but the problem didn’t go away. I tried to install firmware version 300 but it gave me some compatibility errors so i don’t know if I’m making something wrong or the 105 version is just the last version available for this motherboard.

I looked it up, the xxx.1.05 version is the correct one. Though sadly it’s already over 2 years old too.
Anyhow. There were quite a lot of reports in 21/22 about MSI laptops, which could be solved with pci=realloc. You can use the search function of this forum to look them up.
If the kernel keeps reporting problems assigning PCI regions, I doubt the nvidia driver can do much about it. There might be other kernel tweaks, like the acpi_os, but I know too little about them.
One could try a newer kernel using the liquorix ppa.
Otherwise there is talking to MSI and the kernel team, but I don’t know if there is hope in that.