Better performance when NSIGHT is running with OpenGL !!!

Hello,

I have a program that use glDrawArrays with or withour DisplayList or VertexBufferObjects to render near 1000000 points. When i start my program without NSIGHT i have an unstable performance. Some frame take 2ms and others take 40ms. But when i run the same program with NSIGHT all frame take 2ms.

We have a Quaddro 5000 card install in the computer and we made test with different drivers version under Windows 7 64bits. We use NSIGHT version 3.2.2 with Visual Studio 2012.

What can i do to always have the better performance of 2ms without using NSIGHT?

Thank you, Sylvain

Are you measuring the performance with vsync disabled?
If not, try forcing vsync off inside the NVIDIA Display Control panel -> Manage 3D Settings -> Base Profile.
If that is not helping, try additionally to switch to the Workstation - Dynamic Streaming profile.

Same result with vsync off or on. The measure time include glDrawArrays, glFinish but not SwapBuffer.

But, the Dynamic Streaming profile solve my problem.

This profile disable many options but they stay the sames, so what’s the main difference between the base profile and the dynamic streaming profile ?

Thank you, Sylvain

I can’t comment on driver internals, but it’s recommended for applications like your CAVE setup:
http://on-demand.gputechconf.com/gtc/2012/presentations/S0341-Monday-See-Big-Picture-Scalable.pdf
http://www.nvidia.com/docs/IO/127059/quadro-sync-user-guide.pdf

Hi Sylvain,

Which driver are you using?
Also, when you say that you start the problem with Nsight, what exactly are you doing? Graphics debugging (Nsight -> Start Graphics Debugging) and then go into profiling the frame or are you doing API tracing (Nsight -> Start Performance Analysis…)?

Thanks

Hi Rafi,

The last test i made with NSIGHT 3.2.2 is with the drivers version 333.11. I also observe the difference of performance with a previous version of NSIGHT and drivers.

The exact sequence is:

I open my solution.
I choose the release configuration.
I got to the menu NSIGHT, Start Performance Analysis.
In the Trace Settings pane, i enable the OpenGL section (all options).
In the Application Control pane, i press the launch button.

Sylvain