NSight 3.2.2 + VS2012 Pro - Unable to profile Trace with Tools Extension


I need some help locating what caused my NSight profiler to stop working.

First I’ll provide some info & background:

System Spec:
OS: Windows 7 Pro 64bit
Hardware GPU: GeForce Titan GTX
IDE: Visual Studio 2012 update 3
NSIght version 3.2.2
nVidia Display Driver Version: 331.82
Cuda SDK version 5.5

Background info:
I’m developing some MFC graphics application that contains both openGL & openCL.
Project is compiled as 64bit EXE.
Till few hours ago, I had installed NSight 3.1 with display driver version 327.23 & everything worked fine - meaning I could start profiler & get timeline graph.
Only then I realized that some bug that caused me some performance issues when I used the openCL API of “clEnqueueAcquireGLObjects()”. After some “digging” I came across some post on stackoverflow, I understood that was nVidia driver bug that was fixed on 331.x drivers.
So I updated to driver 331.58.
Then when I tried to run profiler with activity type of “Trace Application” & “Trace Settings” set to “Tools Extension”, everytime I click “Launch”, the application never opens, and then I get error saying “no events captured”. Needles to say running application via F5 / Run works just fine.
Same goes for if I change the “Trace Settings” to just “System” (without checking the “Tools Extension”).

I assumed this might be some NSight + driver versions conflict, so i’ve downloaded from internet NSight Visual Studio 3.2.2 & the driver version that is competable with it (version 331.82) & yet, I can’t get it to start application. It’s like - application starts & immediately closes.
I get no error’s or message boxes saying why it’s no opening.
I’ve attempted to see logs for some usefull info, but could not see anything usefull.

Important to mention there is no firewall on PC, and when I do “connect” I get no error’s.
Also, After I’ve installed NSight version 3.2.2, I copies the relevant dll to the EXE bin directory & copied the lib + include to my solution workspace, to link against those.

Can anyone please advise about what can I do to solve this problem ??
(Or at least diagnose why is it not running… ??!)

Would appreciate any help on matter,

Some update:
Even if I rollback to previous Nsight version or driver version it does not work either.
Also, if I try to check “openGL” profile, then I get error message saying CRT not initialized error, R6030.

Seems the installation messed up the PC i’m working on.
I’m having same problem with eith both Visual Studio 2010 & Visual Studio 2012.

I’ve tried to google about R6030 CRT not initailized error with NSight, however found no solutions.
I’ve attempted to re-install the Visual C++ redes. Runtime for both x86 & x64, for 2012 & 2010, but no success.

Apart from “Format” & re-istall windows, can anyone advise what do I need to re-install on PC to make this work again ???


Hi obiOne,

I doubt your Nvidia driver is messed up. Under current situation, could you launch your OpenGL application without Nsight? I suggest you uninstalling driver via Device Manager completely. And then reinstall 331.82. If it doesn’t work, would you mind zip and attach your application here? If it’s too large to attach, I will send you an FTP site. Thanks.