NSight 3.0 fails to collect samples from OpenCL/GL application

I’m attempting to profile an OpenCL application, using Visual Studio 2008 (version 9.0.30729.1) and NVidia NSight (version 3.0). NSight appears to be unable to collect samples from my OpenCL application. Here’s my workflow:

  • I open the NSight menu and click “Start Performance Analysis”
  • I set the “Trace Settings” to inclue OpenCL API Trace, Resource Trace and Command Trace.
  • I hit the “launch” button under application control, then let the application complete.
  • I open up the nvreport. The “Session Overview” says that there was 1 collection error encountered, and that I should see the Session Summary for further information.
  • The session summary does not list any errors. However, it lists the Capture Duration as 0.00 seconds, and the Collection Status of the .nvevents file is “No Events Captured”; the Load Status is “OK”.

I have tried profiling some of NVidia’s sample OpenCL applications, and those all seem to work fine. I’m unsure of how to proceed with debugging this issue. Any suggestions would be appreciated. I’m happy to provide more information if it helps.

Some points that may or may not be relevant:

  • I’m using the OpenCL.lib file that came with the NVidia GPU Computing SDK.
  • My NVidia driver version is 320.49
  • I’m using the OpenCL C++ bindings
  • My application is based on gtest
  • I can acquire system traces just fine. I’ve also successfully acquired OpenGL traces from another gtest-based application.

Thanks in advance for any help!

Tried this with 3.1 RC as well: still no cigar.

This appears to be a bug: NSight is able to collect samples from my test program when I compile it in 32-bit mode. When I compile NVidia’s sample OpenCL programs in 64-bit mode, I receive the same “No Events Captured” message.

Which samples did you try?

First of all, please make sure your 32-bit app could run successfully without Nsight.
For 1 collection error, you may see one or more rows’ collection status is not OK in Session Summary. Please provide that info to us.
So far we cannot repro on our side. Would you mind send your executable files and nvreport file to us? That may help us to investigate a lot. Nvreport file should locate at C:\temp if you haven’t changed the default settings. Please email them to ParallelNsight-Support@nvidia.com. Thanks.