"Pause and Capture" not working

I have VS 2012, and windows 8.1 with a quadro 2000 gpu, and I cannot get Nsight to capture a frame for debugging GLSL. I click “pause and Capture” and I just get a message saying “preparing to capture frame”, how can I get it to capture a frame?

Hi,

What you are doing is correct. Does it ever come back and show you some of the Nsight graphics toolwindows (scrubber, etc)?
Which version of Nsight and driver are you using?
Does the app call Present/swap buffers on every frame?

Thanks

Thanks for responding!! I never see the scrubber and after clicking pause+capture, “resume from capture” never becomes available, I am using the latest version of Nsight 3.2.2.13351 on VS 2012. It is an OpenGL C++ project, and I am using glut and glew.
I am on a Quadro 2000 and my Driver version is 331.82

originally the app only swapped the buffers when changes were made to the scene (such as rotating it etc.) however I updated it so that I call

void animate(int i){
glutTimerFunc(17,animate, 0);
glutPostRedisplay();
}

to get a continuous call to swap the buffers, but I dont get the scrubber, and it looks like it starts another version of the program when I try to pause + capture called replay
screen.png

Hi,

Thanks for the details.
I noticed in the screenshot that it says “GL version: 4.4.0”, is your code using OGL 4.4?
Could you run

<Nsight installation>\Monitor\Common\Nvda.Launcher.100.exe -compatlog c:\nvcompatlog.txt Path\To\MyApp.exe

and see if there’s anything there?

Yes, this is expected (and good), we go ahead and replay the frame. What happens if you select that window? Do you see the HUDs?

Is there a possibility for me to get a hold of the binary or the project to reproduce the issue?

Thanks

Thank you so much once again,

I am not using any OGL 4.4 specific features, I do attach a geometry shader ( I am using it experimentally to detect mouse clicks via ray plane intersections, and I want to debug issues with that).

starting my app with Nvda.Launcher.exe -compatlog causes my program to crash and produces the attached text file and error.

selecting that window does not make any difference

yes no problem how would I go about sending it to you (should I paste a link to dropbox?)
2014-03-11_1449.png
nvcompatlog.txt (4.5 KB)

That’s not good (crash).
Please send me your email address through a private message and I can provide you details.

Thank you

I would also recommend trying out the latest 4.0 release of Nsight.

Hi,
I have the same or similar problem with msvc Nsight 4.0.0.14066. I’m currently using M$VC 10 SP1 and have the suggested driver (334.89). Furthermore I have 3 graphic cards present in my PC: nv 650 Ti, ATI 7950 and intel HD3000 (through virtu control panel). I’m trying to run example application from one of your webinars: Nsight3_2_DebuggingLabs_Siggraph13. It does go to pause and capture but doesn’t give me the scrubber or anything in MSVC IDE. Even no new items under the Nsight>Windows menu.

I have tried many things, including removing the ATI card from PC and so on. But only thing that actualy made it work is to install and use Nsight 3.2.

Hi,

I would suggest opening a new forum topic as it doesn’t sound like it is the same issue.

Which GPU is the application using?

What entries do you see under the Nsight -> Windows menu?

Did you enter frame debugging by selecting Nsight -> Start Graphics Debugging?

Thanks

If you, as a mod, can move my posts to a new thread, go ahead.

Graphics Debug Focus; G. HUD Config.; Shader List

Sure, then I hit ctrl+Z and space or via the menu. It gives me the new window (NV Nsight replay) but I got nothing in MSVC.
To be clear, I’m trying to debug OpenGL and so far I’ve solved all requirements the Nsight asked me to.