VS2012 - Nsight 4.0 - OpenGL 4.2+ Captue frame immediately freezes

When I start debugging my application I can use ctrl+z to bring up the HUD fine, but if I use space or the icon to capture a frame, a green bar very quickly flashes (and appears to fill up) followed by my application crashing. I saved a minidump using the nvidia prompt that pops up, if I open it I get the following:

Unhandled exception at 0x51FBDC65 (Nvda.Graphics.Interception.dll) in .dmp: 0xC0000005: Access violation reading location 0x00000000.

A few notes:

  • This happens whether I am local debugging or remote debugging.
  • I have turned WDDM TDR off on the target machine.
  • I tried Nsight 3.2 and got the same result.
  • I am technically only targeting OpenGL 3.1, but I am capable of getting a 4.4 context.

The dump file is attached.

Any ideas as to what might be causing this?

Thanks in advance.
a8b3f87d-2828-4eb4-894b-2ae05b50a6b5.zip (11.9 KB)

I am having the exact same problem with Nsight 4.0, OpenGL 4.1 context and Visual Studio 2013. I tried the recommended driver and the one auto updating installed me.
I am running this on a MacBook Pro with a GeFore GT 650M.
The application does the OpenGL calls on a dedicated thread.

Having the same issue here more than for a year :(


Thanks for sending along the dump file. I took a look at it but unfortunately it was not conclusive. Is there any possibility of you sending your application to me so that I can take a look at it? You can send me a private message if so.



@danprice Are you an NVIDIA developer? I’m a little wary of sending my application to just anyone. If you are an NVIDIA developer and can provide an NVIDIA email I’d be happy to send to send it along.


Hi, sorry for the confusion – my account wasn’t tagged correctly as an NVIDIA developer. I sent an email to you at your private email.

For those who have similar issues, it turned out to be a minor bug in nsight that will be fixed in the next public build.