Nsight 4.0 RC1 freeze after few frames

Hey I just tried the latest Nsight 4.0 RC1 with no luck :(

When I launch Nsight as “graphics debugging” in VS2012 on a DX11 application the application completely freezes and becomes unresponsive. Frame updates stops working completely and there are no error messages reported whatsoever.

The card I’m using is a GTX 670 and I’ve tried both with driver versions 334 and 335.23

I tried removing logic such that only a device->clear and a device->present call was left and this still happened.

Any directions?

-Yasin

Does your application use any network connectivity where it expects to be able to connect through particular port? We’ve seen instances where an application has failed because the Nsight monitor uses a port that the application expects to be free, leading to application error.

If this is not the case can you try launching through the Nvda.Launcher.exe executable, found in Monitor32/Common? You can drop your executable on it or launch through a command line. Knowing whether this works can help to identify where the problem might be.

Dan

Hey Dan!

Thanks for your reply, dropping my executable on top of Nvda.Launcher works and I get the Nsight hud with the performance counters and graphs running.

I have only a named pipe socket server on my application which is listening for “custom commands” for reloading shaders, materials, entities. That’s as close as we get to networking, which I doubt is the issue.

Where to go from here? :)

-Yasin

Hi Yasin,

Would it be possible for you to create a dump file that we could analyze (see instructions at http://support.microsoft.com/kb/931673)? If you could do that and send me a private message with the dump I will be able to investigate this further.

Until then note that you can still explore some features of our software when run through the launcher by invoking the HUD with CTRL-Z.

Dan

Cool, sent the dump file through pm :)

Thank you!