Black screen on RHEL 7 after upgrade

After the August 2019 patch, all systems cannot start xwindows.
nvidia-bug-report.log.gz (2.39 MB)

Please run as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.


Your xorg.conf is pretty weird, faking a monitor with custom edid but using IgnoreEDID at the same time. Xorg and gnome are running on that fake monitor. Furthermore, running a zaphod heads setup.
What exactly do you want to achieve?

I have two monitors connected to the gpu. was working before with minimal xconfig file generated using nvidia-xconfig. about a months ago it stop working.

All i want if for the monitors to display again using the nvidia drivers.

I revert the configs to bare minimum and have attached a new bug report.

All i want is the to boot to GUI

Ok, the error is:

[    38.141] (WW) NVIDIA(0): No valid modes for
[    38.141] (WW) NVIDIA(0):     "DFP-6:nvidia-auto-select,DFP-4:nvidia-auto-select";
[    38.141] (WW) NVIDIA(0):     removing.
[    38.141] (EE) NVIDIA(0): Unable to use default mode "nvidia-auto-select".
[    38.141] (EE) NVIDIA(0): Failing initialization of X screen

Please use this as xorg.conf:

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BusID "PCI:59:0:0"
    Option "ModeDebug" "true"

Afterwards, create a new nvidia-bug-report.log and attach it.

the new bug report attached

Those are single resolution 2560x1600 monitors, 268MHz pixel clock but the connection is only detected as HDMI 1.0, 165MHz pixel clock so it doesn’t work.
Do you use any converters/adapters to connect the monitors?

Yes we use an extender to connect the system to office from the server room. These connections worked before for many years.

will remove the extenders and adapters, then bring the monitor to the server room, connect directly and test then get back to you

The driver might have changed thresholds so now it only negotiates to hdmi 1.0 speeds instead of hdmi 1.3 (340MHz). Do you know which driver version you previously had which worked, i.e. did you already try to downgrade the driver?

Yes i did downgrade to the driver and kernel and not different. I am starting the believe the extenders are he culprits here.

Tomorrow we will take one of the monitors and use a direct connection to confirm.

So how can i increase the threshold. downgrading the driver and kernel do not fix the issue. connecting a different but smaller monitor works. But we need the big monitors.

If downgrading the driver to the last known working one doesn’t help, this isn’t driver/thresholds (which can’t be adjusted, driver internal) related. This rather points to something in the external signal way changed, e.g. an additional source of electrical interference increasing error rates.
Which extender model are you using?

this maybe an issue with the GPP display ports because i have an older gpu with one DVI port and a Display port. After all the configs the DVI is working but the Display is not. Attached the bug report.