External monitor undetected in Ubuntu 18.04, Inspiron 5593, Nvidia GeForce MX230

The external HDMI monitor is unseen in my Ubuntu partition. Moreover I cannot change my display setting of the integrated monitor (resolution, refresh, etc.)

xrandr command reports:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
1920x1080 77.00*

I tried several versions of nvidia drivers and x.org, I installed Ubuntu and Xubuntu, I tried lightdm and gdm3, nothing worked.

I found somebody having a similar issues in this thread: https://www.dell.com/community/Precision-Mobile-Workstations/External-Monitor-not-working-Ubuntu-nvidia/td-p/6241315 but the solution proposed doesn’t work.

Any advice?

attached the nvidia-bug-report.log
nvidia-bug-report.log.gz (1.08 MB)

It’s trucated, please attach as file. Hovering the mouse over an existing post of yours will reveal a paperclip icon.

done… thanks to let me notice

done… thanks to let me notice

Your cpu is too new for the currently running kernel. Please upgrade to kernel 5.3 e.g. by installing the edge hwe
sudo apt-get install --install-recommends linux-generic-hwe-18.04-edge

Great! Thank you so much, now it works perfectly!