Boot error when trying to install RHEL 9.3

When I try and download RHEL 9.3 I get the error above. I am using a Nvidia RTX 4080 graphics card and was referred to Nvidia support by RedHat support. They believed it was a graphics driver issue. Any help on how to resolve this would be much appreciated.

Thank you

Tesla T4 on Dell PowerEdge r440:

I had to add “i915.modeset=0 rd.driver.blacklist=nouveau” to grub as nouveau conflicted. Here is what I had to do because of the bug mentioned in notes below.

#----- Becuase of current bug: Nvidia driver not loading after installation

dnf -y install kmod-nvidia-latest-dkms

Ensure that nvidia modules are built or build them:
dkms status
nvidia/515.65.01, 5.17.5-300.fc36.x86_64, x86_64: installed
# build with
# sudo dkms install nvidia/515.65.01 -k 5.17.5-300.fc36.x86_64

Ensure I’ve got something like this:
cat /etc/modprobe.d/nouveau-blacklist.conf
blacklist nouveau
options nouveau modeset=0

dracut -v -f --regenerate-all --omit-drivers=“nouveau i915” --force-drivers=“nvidia_drm nvidia_modeset nvidia_uvm nvidia”

vi /etc/default/grub
GRUB_CMDLINE_LINUX=“crashkernel=1G-4G:192M,4G-64G:256M,64G-:512M resume=/dev/mapper/rl_ssd-swap rd.lvm.lv=rl_ssd/root rd.lvm.lv=rl_ssd/swap ipv6.disable=1 rd.driver.blacklist=nouveau”

change to

GRUB_CMDLINE_LINUX="crashkernel=1G-4G:192M,4G-64G:256M,64G-:512M resume=/dev/mapper/rl_ssd-swap rd.lvm.lv=rl_ssd/root rd.lvm.lv=rl_ssd/swap ipv6.disable=0 	nouveau.modeset=0 rd.driver.blacklist=nouveau i915.modeset=0 nvidia-drm.modeset=1"

grub2-mkconfig -o /boot/grub2/grub.cfg

#— end of current bug as of 20230823