Bootloop after install SPI device

Hi everyone,

My Jetson TX2 stucks in a bootloop after I installed the spi device. I followed the instruction from this Website: https://elinux.org/Jetson/TX2_SPI

My L4T-Version is R28.2.1. For building the kernel I used the scripts from JetsonHacks.

The verifying of the SPIDev module worked fine.

The installing of the DTC Tool, decompiling, updating and recompiling the device tree worked also fine.

Then I flashed the DTB with the flash.sh script from a host device. Then, after rebooting, the system stucks in a bootloop. I can’t read it so fast, because it is rebooting after a few seconds.

I flashed the original DTB and the system works well again. So, the problem has to be in flashing the device tree or I wrote something wrong into the dts, but I followed the instruction step by step and insert the device tree patch on the right position.

I skipped the last step to enable the FDT in /boot/extlinux.conf because I flashed it with the flash.sh script before.

I hope you can help me to get this to work.

Thank you and best regards

r.wydra

I can’t say for sure, but I suspect the problem is the installation of the device tree. It looks like the article you are using for procedure is from a release where device tree did not require signing. I am guessing that if you use the flash tools to install the device tree, then it should work.

See official docs, plus:

Hi linuxdev,

thank you very much for your reply and exuse me for my late answer. I didn’t have internet over the weekend.

I read about signing the device tree before, but I thought this is done automatically by the flashing script flash.sh.

I will try your suggestions and will give you a feedback about the results.

Cheers,
r.wydra

Ohh my God! I solved the problem. It was so silly that it can’t be so silly…

I figured out that the SD-Card, which I used to transfer the dts File from /dev/device-tree, does that the Jetson TX2 can’t boot and stuck in the boot loop.

It was a coincidence this time, I let the SD-Card in my Host device and didn’t plugged it in the Jetson back again. And surprise, it works now…

Soo everything was fine and the manual on the website https://elinux.org/Jetson/TX2_SPI still works. The flashing script flash.sh performs automatically the signing. I read it in the flashing log, from your second link.

Next time unplug all unnecessary devices from the Jetson :)

Thank you guys for your help and this great forum! It contains a lot of helpful informations. Go on please! :D

Serious researchers in design patterns for errors refer to this as “well, duh!”. Sorry, couldn’t resist, one of my old colleagues came up with this :P Glad it worked out without lots of grief.