Jetson Tx2 not mounted as external drive on host machine during JetPack 4.2 installation


I’ve successfully flashed my Jetson Tx2 with the JetPack 4.2, but I’m not able to finish the installation of the SDK after booting the board into OS. I’ve read on other threads that that the board should appear as mounted drive on my host machine, but that does not happen. The board is connected obviously with the USB cable to my host machine.

Any ideas on how to fix this?



Hi bogdan0kg3v,

Are you means, after flash and boot into Desktop, you can’t install SDK components?
If yes, please check your usb device mode is up:

  • Jetson device:
  • Host machine:

You can check more FAQ from:

Hi there,

I do not get L4T-README folder mounted on my host machine. Also, I do not get assigned to host machine as well. Going through the link from above did not help.

FYI, the code in “/opt/nvidia/l4t-usb-device-mode/” is demo code (there is an exception listed at the bottom) producing both a tiny mountable read-only block device (the hard drive part), and the virtual ethernet over USB. The block device will only mount if the host was set up to do so (and additionally, if a VM, then it won’t pass through if you don’t tell it to). The network virtual device is used during the step which follows flash (package additions), but your host may not be set up to use that device and might require manual intervention. In no case is the sample block device related in any way to flash or package addition, and this content will not have access to the Jetson’s filesystem.

Is this a VM?

If you have your TX2 turned off, but the micro-B USB cable is connected to a host, and if you monitor “dmesg --follow”, then as the TX2 boots you should see some variation on this (mine is sdg simply because of what disks I already have):

[10470.690170] sd 10:0:0:0: [sdg] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[10470.692417]  <b>sdg</b>:
[10470.693145] sd 10:0:0:0: [sdg] Attached SCSI removable disk

If I now run “lsblk -f /dev/sdg” I see:

NAME FSTYPE LABEL      UUID                                 MOUNTPOINT
sdg  vfat   L4T-README 3D81-AAFA

I have not set this up for auto mount. If you see something like the above, then if it wasn’t auto mounted you would have to manually mount this. The content from the mount will have zero access to the rest of the Jetson’s file system, and would have no ability to deal with installation of software, so on. The script in “/opt/nvidia/l4t-usb-device-mode/” was just an example and could be edited to change what becomes visible.

The same script which sets up the bulk storage emulation also sets up the virtual ethernet device. Originally even the ethernet device was just example code, but as of SDK Manager 4.2 this ethernet device is substituted for an ethernet port actual device (this is still wired ethernet, but it is wired over USB).