Cannot install Jetson SDK components

There are multiple posts about people being unable to install the SDK components, however they get very confusing with multiple people posting over the top of each other, so I’m creating one for myself.

I have successfully flashed the OS 4.2 and have restarted the device so it is no longer in force recovery mode. When the sdkmanager attempts to install the SDK components, it is unable to connect to the TX2.

On the Jetson, the ip address of interface l4tbr0 is 192.168.55.1, however the host cannot seem to see the Jetson at all. I don’t see anything change when running dmesg after plugging in the USB. I’ve tried multiple cables and hosts.

The only errors I see when running journalctl -u nv-l4t-usb-device-mode and journalctl -u nv-l4t-usb-device-mode is “No subnet declaration for usb0|rndis0|eth0”

Not sure what else to try…

Hi abc9ag3c,

Please try below few things:

  1. Unplug and plug-in micro-usb cable
  2. Check your host machine via ifconfig:
  • Jetson device: 192.168.55.1
  • Host machine: 192.168.55.100 (You can see one config like "enp0s26u1u1")
  1. Make sure usb-device mode is up, then install sdk components again.

Hi,

  1. Doesn’t help
  2. The Jeston is 192.168.55.1, the host does not have any config like that. Like everyone else who is having this issue, it seems the USB networking isn’t being configured correctly.

Thanks

Hi abc9ag3c,

Please reference FAQ Q2: usb-device mode is already up and running, however, 192.168.55.100 not assigned on host. Why?
https://devtalk.nvidia.com/default/topic/1050477/jetson-tx2/jetpack4-2-flashing-issues-and-how-to-resolve/

  • Host machine is support Ubuntu 16.04 and 18.04 (not support VM).

Thanks,

I’ve gone through all those posts. I tried to cover these things in my initial post. dmesg shows nothing.

FYI, if the Jetson itself shows the USB-based ethernet address, then all remaining configuration is on the host side. Therein is the source of most issues of using this for adding packages. The SDK Manager software is trying to tell the host to enable this alternate network and allow the USB ethernet, but fails to do so. One issue might be that at the moment SDKM tried to configure this the host PC did not see the USB…in which cause disconnecting and reconnecting the USB cable itself might help (USB is hot plug and will send an event to the system). Anything you do with the config tool from the GUI to enable this after a hot plug would also work (it doesn’t have to be SDKM which does the configure).

“dmesg” is one place where many hot plug events are logged. If an event is seen there, then you know the ethernet over USB can succeed after configuration of the host PC. If not, then probably something else is going on. A VM is commonly a problem for not passing things on to the guest o/s.

Thanks for the info. Is there a way to manually trigger the SDK manager to try and set up the USB ethernet on the host side? Obviously it’s not working, but maybe that could give me some information about what has gone wrong and how I might address the issue.

This is not a VM, so I’m hoping that someone can give me some information on how I can debug this.

Hi abc9ag3c,
SDK Manager needs a way to ssh connect to Jetson device (192.168.55.1) from host to install SDK components. The IP address of the host machine is expected to be 192.168.55.100. If it is not automatically assigned, could you please check the usb-ethernet port on your host machine, and assign it manually? Please refer to https://devtalk.nvidia.com/default/topic/1049213/jetson-agx-xavier/jetson-sdk-components-recovery-mode-problem/post/5329481/#5329481 for a similar issue.

Hi,

The issue is there is no USB ethernet interface on the host machine. Per the link you gave, there should be 2 new interfaces, however I still only have the usual ethernet and loopback interfaces. Is there a way to manually configure the host to ad them?

Thanks

Hi abc9ag3c,

Could you please RMA the device per process https://developer.nvidia.com/embedded/faq#rma-process ?

Thanks

Hi,

I’m confused as to why it would need to be RMA’d? My understanding is the TX2 is working correctly, it’s just the setup on the host side that has had issues. Isn’t the solution to this problem just getting the usb-ethernet interface set up correctly?

I have tried another TX2, and I am getting the exact same results.

Hi abc9ag3c,

As there are no kernel logs on the host when plugging/unplugging the flashing cable. The only thing we can think of is bad HW. Our engineer has seen this problem happen when using a bad USB cable; replacing it fixed this in some cases. However, as you have tried “multiple cables and hosts”, I think this is not caused by usb-cable/usb-port/hosts. Therefore, we need it to be RMA’d to check why usb-ethernet interface cannot be set up correctly.

Thanks for your time.

It appears to be the breakout board. I was using a Connect Tech Elroy which doesn’t seem to bring up the USB on normal boot (but it does in recovery mode). By swapping to an old Connect Tech Astro, using the dip switches I was able to get it to connect.

Thanks abc9ag3c,
I’ll mark this issue as solved per comment #14 above.

It is not the breakout board. I had the same problem on all my TX2s but found this fix to work…

Make sure the appropriate modules are loaded on the host (noone has complained that this is a problem)

root@host:~# lsmod | grep rndis
rndis_wlan             57344  0
rndis_host             16384  1 rndis_wlan
cfg80211              622592  1 rndis_wlan
cdc_ether              16384  1 rndis_host
usbnet                 45056  3 rndis_host,cdc_ether,rndis_wlan

The lsusb command will also check to see if the L4T-usb-device is mounted. Assign the aforementioned address to the usb0 device (mine was renamed)

root@host:~# ifconfig enp0s26f7u1i5 192.168.55.100

Then ssh into 192.168.55.1 using the account you set up earlier in the install and upgrade your Jetson (am not sure you need dist-upgrade)

root@target:~# apt-get update && apt-get upgrade
root@target:~# apt-get dist-upgrade
root@target:~# reboot

After that the sdkmanager worked as advertised. You may need to reassign the IP address to your host’s usb0 device. It will disappear when you reboot the TX2. Am not sure what got upgraded on L4T to make it work. Maybe a newer dhcpd version. Also, you could upgrade your TX2 in a more conventional fashion if you have a keyboard and mouse on it. I set my TX2’s wifi connection up right after the System configuration wizard so I had internet access.

Note that you do not want to start over in SDKM… you already successfully installed the Jetson OS (and then the upgrade). Unclick it and just install the SDK components. You should not get a recovery mode error any more. It worked for me.

I had a similar issue.
I tried the following and it worked:

  1. before plugging the usb cable to my host, I ran
ip addr

on the host, to see which interface were up.
2) I plugged the usb cable to the tx2 and ran

ip addr

again on the host to see which new interfaces poped. In fact two new interfaces were up with names enp57s0u1u3 and enp57s0u1u3i5.
3) I ran

sudo ifconfig <enp57s0u1u3> 192.168.55.100
  1. I launched the SDK step 3 (installation of components part) right away

This approach seems to work.
Hope that can help.

1 Like

I had a similar issue and Thomas Carle solution fixed it. Thanks!

For me, the issue was with the IP address on the target Jetson device was different from the one expected by the sdk manager.
To get the correct Ip address of the Jetson device, I connected it a display, logged in and then ran the ifconfig to get the Ip address.

I then used this IP address in the SDK manager dialog and that solved the issue.