SDK Manager Flashes new Jetpack 4.2 correctly but then cannot install SDK Components

I followed all the instructions in the jetson tx2 board

Complete the Wizard.
Wait for The OS Login
Enter the username and password.
And the click Install on SDK Manager.

But it says that Could not connect to target device…

Any Options?? Any tutorial to install with the downloaded debs?

Hi isra601988,

Can you ssh from your host machine to 192.168.55.1 (target IP) with the username and password?
Could you please provide the screenshot and files in ~/.nvsdkm/ folder?

Nope. I cannot ssh to that IP. I see that IP in the jetson Tx2 configured on the l4trb0 interface.
I have my usb cable connected (the same with I flashed the board).

The content of the downloads folder:

cuda-repo-l4t-10-0-local-10.0.166_1.0-1_arm64.deb
graphsurgeon-tf_5.0.6-1+cuda10.0_arm64.deb
Jetson_Linux_R32.1.0_aarch64.tbz2
libcudnn7_7.3.1.28-1+cuda10.0_arm64.deb
libcudnn7-dev_7.3.1.28-1+cuda10.0_arm64.deb
libcudnn7-doc_7.3.1.28-1+cuda10.0_arm64.deb
libnvinfer5_5.0.6-1+cuda10.0_arm64.deb
libnvinfer-dev_5.0.6-1+cuda10.0_arm64.deb
libnvinfer-samples_5.0.6-1+cuda10.0_all.deb
libopencv_3.3.1-2-g31ccdfe11_arm64.deb
libopencv-dev_3.3.1-2-g31ccdfe11_arm64.deb
libopencv-python_3.3.1-2-g31ccdfe11_arm64.deb
libopencv-samples_3.3.1-2-g31ccdfe11_arm64.deb
libvisionworks-repo_1.6.0.500n_arm64.deb
libvisionworks-sfm-repo_0.90.4_arm64.deb
libvisionworks-tracking-repo_0.88.2_arm64.deb
python3-libnvinfer_5.0.6-1+cuda10.0_arm64.deb
python3-libnvinfer-dev_5.0.6-1+cuda10.0_arm64.deb
python-libnvinfer_5.0.6-1+cuda10.0_arm64.deb
python-libnvinfer-dev_5.0.6-1+cuda10.0_arm64.deb
sdkml3_jetpack_l4t_42.json
Tegra_Linux_Sample-Root-Filesystem_R32.1.0_aarch64.tbz2
Tegra_Multimedia_API_R32.1.0_aarch64.tbz2
tensorrt_5.0.6.3-1+cuda10.0_arm64.deb
uff-converter-tf_5.0.6-1+cuda10.0_arm64.

Can you please paste the IP address of the usb-ethernet ports on your host machine? The usb-ethernet ports name may be usb0/usb1 or enps[Y]u[Z]; X, Y, and Z here may be different numbers on different machines.
You may use ip addr command on your host machine to check it.
The expected result is that 192.168.55.100 assigned to one of the ports. And it should be assigned when below two conditions are met:

  1. USB cable is connected between host and target.
  2. Ubuntu desktop is shown on jetson device after login.

With ip addr, I cannot see any usb-ethernet interface…

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether ec:f4:bb:16:6e:49 brd ff:ff:ff:ff:ff:ff
    inet 10.50.83.32/16 brd 10.50.255.255 scope global eno1
       valid_lft forever preferred_lft forever
    inet 192.168.3.232/24 brd 192.168.3.255 scope global eno1
       valid_lft forever preferred_lft forever
    inet 192.168.55.232/24 brd 192.168.55.255 scope global eno1
       valid_lft forever preferred_lft forever
    inet6 fe80::af07:f07e:4d06:780a/64 scope link 
       valid_lft forever preferred_lft forever
3: wlp3s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether c4:d9:87:4e:b4:fc brd ff:ff:ff:ff:ff:ff

Also with lsusb this is the output.

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0c45:649d Microdia 
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Can you please check if the usb cable is connected between host and jetson device? It seems the usb hardware connection is broken.
Please also make sure the device is booted up and you have logged in device with the newly created username and password.

Yeah. The cable is connected… (if I put the board in recovery mode then the sdkmanager says board is in recovery mode)

Is the same usb cable I used for flashing the Tegra…

If I try to ssh with the ethernet interface… For example ssh ubuntu@10.50.84.70 (Manual ip) then it works. I can enter…

So is there any way to manual install this debs?? Maybe the script that use sdkmanager?? Before with Jetpack I could check to install the SDK Components individually and now I have to install all…

SDK manager is using usb cable only to flash device and install all target components. Could you please change a different USB port on host, or change another USB cable to try to fix the problem?

I tried with another port… The cable seems to work becouse I could flash the Jetson with 4.2 Jetson OS.

Now it says incorrect username or password… but I put the correct name and password (I can login on my Jetson OS).

This is the terminal log of sdkmanager.

07:45:20 DEBUG : running command < ip addr | grep 192.168.55.100/24 >
07:45:20 INFO : inet [01;31m [K192.168.55.100/24 [m [K brd 192.168.55.255 scope global eno1
07:45:20 INFO : command finished successfully
07:45:20 DEBUG : running command < ssh -F /dev/null -o PubkeyAuthentication=no -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -o ConnectTimeout=5 ubuntu@192.168.55.1 echo hello >
07:45:25 INFO : ssh: connect to host 192.168.55.1 port 22: Connection timed out
07:45:25 ERROR : command terminated with error
07:45:25 ERROR : Incorrect username or password
07:46:55 DEBUG : running command < ip addr | grep 192.168.55.100/24 >
07:46:55 INFO : inet [01;31m [K192.168.55.100/24 [m [K brd 192.168.55.255 scope global eno1
07:46:55 INFO : command finished successfully
07:46:55 DEBUG : running command < ssh -F /dev/null -o PubkeyAuthentication=no -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -o ConnectTimeout=5 ubuntu@192.168.55.1 echo hello >
07:47:00 INFO : ssh: connect to host 192.168.55.1 port 22: Connection timed out
07:47:00 ERROR : command terminated with error
07:47:00 ERROR : Incorrect username or password
07:47:16 DEBUG : running command < ip addr | grep 192.168.55.100/24 >
07:47:16 INFO : inet [01;31m [K192.168.55.100/24 [m [K brd 192.168.55.255 scope global eno1
07:47:16 INFO : command finished successfully
07:47:16 DEBUG : running command < ssh -F /dev/null -o PubkeyAuthentication=no -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -o ConnectTimeout=5 ubuntu@192.168.55.1 echo hello >
07:47:21 INFO : ssh: connect to host 192.168.55.1 port 22: Connection timed out
07:47:21 ERROR : command terminated with error
07:47:21 ERROR : Incorrect username or password
07:49:43 INFO : Device Mode Host Setup in Target SDK : install ‘Device Mode Host Setup in Target SDK’ Skipped
07:49:43 INFO : DateTime Target Setup : install ‘DateTime Target Setup’ Skipped
07:49:43 INFO : CUDA Toolkit for L4T : install ‘CUDA Toolkit for L4T’ Skipped
07:49:43 INFO : cuDNN on Target : install ‘cuDNN on Target’ Skipped
07:49:43 INFO : TensorRT on Target : install ‘TensorRT on Target’ Skipped
07:49:43 INFO : OpenCV on Target : install ‘OpenCV on Target’ Skipped
07:49:43 INFO : VisionWorks on Target : install ‘VisionWorks on Target’ Skipped
07:49:43 INFO : Multimedia API : install ‘Multimedia API’ Skipped
07:49:44 INFO : All done!

Hi isra601988,

Could you please try the below steps?

  1. Run “dmesg” on the host and provide the full output. This might show any errors the host might have had when enumerating the Jetson USB device.

Now, connect jetson device with a ethernet cable, get its IP address, ssh to Jetson and:

  1. Run “journalctl -u nv-l4t-usb-device-mode” to show any errors configuring the USB device mode service on Jetson, during boot.

  2. As root, run “/opt/nvidia/l4t-usb-device-mode/nv-l4t-usb-device-mode-stop.sh”. This is expected to show some errors; ignore them.

  3. As root, run “bash -x /opt/nvidia/l4t-usb-device-mode/nv-l4t-usb-device-mode.sh” and provide the entire output that prints. This should (a) show the same errors as in (2) above, and/or (b) actually make L4T USB device mode work, if the reason it failed the first time was due to some missing dependency that wasn’t available right when the script ran at boot.

Hi, I had the same issue and this is output after running bash -x /opt/nvidia/l4t-usb-device-mode/nv-l4t-usb-device-mode.sh

  • set -e
    +++ dirname /opt/nvidia/l4t-usb-device-mode/nv-l4t-usb-device-mode.sh
    ++ cd /opt/nvidia/l4t-usb-device-mode
    ++ pwd
  • script_dir=/opt/nvidia/l4t-usb-device-mode
  • enable_rndis=1
  • enable_acm=1
  • enable_ecm=1
  • enable_ums=1
  • net_ip=192.168.55.1
  • net_mask=255.255.255.0
  • net_net=192.168.55.0
  • net_dhcp_start=192.168.55.100
  • net_dhcp_end=192.168.55.100
  • net_dhcp_lease_time=15
  • net_ipv6=fe80::1
  • net_ipv4_defroute_router=192.168.55.100
  • net_ipv4_defroute_metric=32766
  • fs_img=/opt/nvidia/l4t-usb-device-mode/filesystem.img
  • udc_dev_t210=700d0000.xudc
  • ‘[’ -e /sys/class/udc/700d0000.xudc ‘]’
  • udc_dev_t186=3550000.xudc
  • ‘[’ -e /sys/class/udc/3550000.xudc ‘]’
  • udc_dev=3550000.xudc
  • ‘[’ 3550000.xudc == ‘’ ‘]’
  • macs_file=/opt/nvidia/l4t-usb-device-mode/mac-addresses
  • ‘[’ -f /opt/nvidia/l4t-usb-device-mode/mac-addresses ‘]’
  • . /opt/nvidia/l4t-usb-device-mode/mac-addresses
    ++ mac_rndis_h=62:6e:b3:35:3e:60
    ++ mac_rndis_d=62:6e:b3:35:3e:61
    ++ mac_ecm_h=62:6e:b3:35:3e:62
    ++ mac_ecm_d=62:6e:b3:35:3e:63
  • mkdir -p /sys/kernel/config/usb_gadget/l4t
  • cd /sys/kernel/config/usb_gadget/l4t
  • echo 0x0955
  • echo 0x7020
  • echo 0x0001
  • echo 0xEF
  • echo 0x02
  • echo 0x01
  • mkdir -p strings/0x409
  • cat /proc/device-tree/serial-number
  • echo NVIDIA
  • echo ‘Linux for Tegra’
  • cfg=configs/c.1
  • mkdir -p configs/c.1
  • cfg_str=
  • ‘[’ 1 -eq 1 ‘]’
  • cfg_str=+RNDIS
  • func=functions/rndis.usb0
  • mkdir -p functions/rndis.usb0
  • echo 62:6e:b3:35:3e:60
  • echo 62:6e:b3:35:3e:61
  • ln -sf functions/rndis.usb0 configs/c.1
  • echo 1
  • echo 0xcd
  • echo MSFT100
  • echo RNDIS
  • echo 5162001
  • ln -sf configs/c.1 os_desc
  • ‘[’ 1 -eq 1 ‘]’
  • cfg_str=+RNDIS+ACM
  • func=functions/acm.GS0
  • mkdir -p functions/acm.GS0
  • ln -sf functions/acm.GS0 configs/c.1
  • ‘[’ 1 -eq 1 ‘]’
  • cfg_str=+RNDIS+ACM+UMS
  • func=functions/mass_storage.0
  • mkdir -p functions/mass_storage.0
  • ln -sf functions/mass_storage.0 configs/c.1
  • echo 1
  • echo /opt/nvidia/l4t-usb-device-mode/filesystem.img
  • ‘[’ 1 -eq 1 ‘]’
  • cfg_str=+RNDIS+ACM+UMS+ECM
  • func=functions/ecm.usb0
  • mkdir -p functions/ecm.usb0
  • echo 62:6e:b3:35:3e:62
  • echo 62:6e:b3:35:3e:63
  • ln -sf functions/ecm.usb0 configs/c.1
  • mkdir -p configs/c.1/strings/0x409
  • echo RNDIS+ACM+UMS+ECM
  • echo 3550000.xudc
  • /sbin/brctl addbr l4tbr0
  • /sbin/ifconfig l4tbr0 192.168.55.1 netmask 255.255.255.0 up
  • /sbin/ifconfig l4tbr0 add fe80::1
  • ‘[’ 1 -eq 1 ‘]’
    ++ cat functions/rndis.usb0/ifname
  • /sbin/brctl addif l4tbr0 rndis0
    ++ cat functions/rndis.usb0/ifname
  • /sbin/ifconfig rndis0 up
  • ‘[’ 1 -eq 1 ‘]’
    ++ cat functions/ecm.usb0/ifname
  • /sbin/brctl addif l4tbr0 usb0
    ++ cat functions/ecm.usb0/ifname
  • /sbin/ifconfig usb0 up
  • cd -
    /root
  • /sbin/losetup -f -r /opt/nvidia/l4t-usb-device-mode/filesystem.img
  • ‘[’ -n 192.168.55.100 ‘]’
  • dhcpd_conf=/opt/nvidia/l4t-usb-device-mode/dhcpd.conf
  • dhcpd_leases=/opt/nvidia/l4t-usb-device-mode/dhcpd.leases
  • dhcpd_pid=/opt/nvidia/l4t-usb-device-mode/dhcpd.pid
  • cat
  • rm -f /opt/nvidia/l4t-usb-device-mode/dhcpd.leases
  • touch /opt/nvidia/l4t-usb-device-mode/dhcpd.leases
  • /usr/sbin/dhcpd -cf /opt/nvidia/l4t-usb-device-mode/dhcpd.conf -pf /opt/nvidia/l4t-usb-device-mode/dhcpd.pid -lf /opt/nvidia/l4t-usb-device-mode/dhcpd.leases
    Internet Systems Consortium DHCP Server 4.3.5
    Copyright 2004-2016 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/
    Config file: /opt/nvidia/l4t-usb-device-mode/dhcpd.conf
    Database file: /opt/nvidia/l4t-usb-device-mode/dhcpd.leases
    PID file: /opt/nvidia/l4t-usb-device-mode/dhcpd.pid
    Wrote 0 leases to leases file.
    Listening on LPF/l4tbr0/62:6e:b3:35:3e:61/192.168.55.0/24
    Sending on LPF/l4tbr0/62:6e:b3:35:3e:61/192.168.55.0/24

No subnet declaration for usb0 (no IPv4 addresses).
** Ignoring requests on usb0. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface usb0 is attached. **

No subnet declaration for rndis0 (no IPv4 addresses).
** Ignoring requests on rndis0. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface rndis0 is attached. **

No subnet declaration for wlan0 (no IPv4 addresses).
** Ignoring requests on wlan0. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface wlan0 is attached. **

No subnet declaration for eth0 (10.1.15.35).
** Ignoring requests on eth0. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface eth0 is attached. **

Sending on Socket/fallback/fallback-net

  • ‘[’ -n 192.168.55.100 ‘]’
  • route add default gw 192.168.55.100 dev l4tbr0 metric 32766
  • exit 0

Hi nrj127 & isra601988,
I had the same problem which you are going through. I was able to flash the Jetson board but the sdk components failed with the message “jetson is in recovery mode”.

This failure is due to the USB ethernet connection between the Host PC and Jetson board. Kindly follow these steps and your issue might be resolved.

  1. Disconnect and Connect the USB cable connecting the jetson and Host-PC, and check the dmesg log.
    You might see a log similar to this:

[107833.388835] cdc_ether 2-2:1.5 usb1: register ‘cdc_ether’ at usb-0000:00:14.0-2, CDC Ethernet Device, 72:40:f7:72:c9:fa

  1. Next go to Settings->Network and check all the wired connections for the same MAC-address.

  2. In the top right corner there will be an option to enable it.

  3. Next follow the procedure as provided by the SDK manager to install the SDK components

Hi nrj127,
The command output looks good. If your run “ip addr” command on your host machine, can you see “192.168.55.100”? If not, can you please check if Waiss’s suggestion above can solve your issue? (Thanks Waiss for sharing the experience.)

I had the same problem. I was able to flash the Jetson board but the sdk components failed with the message.

B cable. 2. Ubuntu ‘System configuration wizard’ is completed on the device. 3. Jetson’s Ubuntu OS is up and running.
21:44:22 DEBUG : running command < ip addr | grep 192.168.55.100/24 >
21:44:22 ERROR : command terminated with error

I had the same problem too. I was able to flash the Jetson (TX2/Xavier) board but the sdk components failed

I have the same problems. After a successful flash and with the OS up and running, including wifi configuration, I cannot install the SDK components.

I think the problem is that for some reasons, the SDK manager needs to see the TX2 attached via USB and it cannot.

See the errors:

12:45:10 DEBUG : running command < lsusb | grep “NVidia Corp” >
12:45:11 ERROR : command terminated with error

Hi stevefoy, chenscottusa & benelgiac,
Are you still running into this issue after enabling the USB ethernet in the network settings? I have shared my work around in the previous comment.

Hi stevefoy,
Can you please paste the output of command “ip addr | grep 192.168.55.100”? And also see if the FAQ https://devtalk.nvidia.com/default/topic/1050477/jetson-tx2/jetpack4-2-flashing-issues-and-how-to-resolve/ helps?

Hi Chenscottusa, benelgiac,
Can you please check the FAQ https://devtalk.nvidia.com/default/topic/1050477/jetson-tx2/jetpack4-2-flashing-issues-and-how-to-resolve/ helps?

I using the VMWare VM ubuntu 18.04/16.04, after the flash, the jetson restart, the USB device fails to attach to the VM.

I manually download all the SDK components, copy and install in the jetson.

Why not ask the LAN ip address instead of using the USB network? or release the scripts so we can do it by ourselves?