Brightness/backlight sysfs knob does not work in 525.89.02 or 530.30.02


I have a Dell Precision 7760 with an A5000 used in discrete-only graphics mode. I can’t adjust the backlight brightness on this laptop by using /sys/class/backlight/nvidia_0/brightness (either write()ing ASCII decimal strings from 0 to 100 manually or by using xbacklight) when using the proprietary driver at version 525.89.02 or 530.30.02. This still works with 515.86.01, which I am now currently running again. I don’t have an nvidia-bug-report.log.gz to share. I can get and post one, if necessary, but switching graphics driver versions is inconvenient.

Update: I just tried 535.86.05 on a boring, unpatched build of 6.3.13. I have nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1 acpi_backlight=native in my GRUB_CMDLINE_LINUX_DEFAULT. Backlight control still doesn’t work, despite what is claimed in Brightness on a Lenovo ThinkPad P52 no longer controllable after updating nvidia-drivers to 525.xx series - #21 by amrits.

Install Kubuntu 22.04 or kDE Neon with OEM kernel 6.2+
22.04 is hardware certified for your model.
Update bios.
Install the complete and correct kernel parameters.
Install nvidia 535.
Check your system.
Is the nvidia driver fully loaded>
Does dell_wmi need to be loaded?

Prove to yoursellf the the invidia driver is installed absolutely correctly.
Check lsmod to see what is loaded for video and if dell_wmi is loaded.

Ubuntu 22.04 ( ecosystem) is certified for your exact hardware.
22.04 can be crafted to be as nearly as bleeding as Arch but 1000% more stable if you use the right sources and PPA.

Dell has their own Ubuntu 22.04 repos for their hardware.
In the normal repo you can install the OEM 6.02 kernel and OEM keyring.
I suspect the 22.04 OEM 6.02 kernel would resolve your issue most likely having the dell_wmi module option enabled by default.

I suggest using.
Latest Production Branch Version:
[535.86.05] or what ever the Latest Production Branch Version is.



“Please also generate and post an “nvidia bug report” by running as root.”

Have you read your sudo dmesg?

A Hardware / Software issue requires Hardware/ Software information to formulated a Hardware / Software Solution.

The amount, accuracy and relevance of the Hardware/ Software information provided is directly indicative of the amount, accuracy and relevance of the Hardware/ Software solution formulated.

Have you Read The Fantasic Manual?

Have you Read This Fantasic Manual?

Have you read this?

My advice.
Update your bios as per the exact manufacturers instructions and flash using this method twice.
Install kde-neon or kubuntu 22.04.

Your exact model certified on Ubuntu 22.04.

Install package manager Synaptic. Synaptic is GOD.
Do NOT install “with recommends” on kde neon or Kubuntu.

Install the 6.02 OEM Kernel.

Install the correct kernel parameters.
define the correct ACPI profile to be used: acpi_osi='Windows 2017
Is acpi_osi='Windows 2017 correct?

define the ACPI resources mode as instructed in the official nVidia README:

What are your kernel parameters at boot?
What ACPI profile are you using? Is acpi/ acpid installed and running.

Example only:
GRUB_CMDLINE_LINUX_DEFAULT=“acpi_osi='Windows 2017 acpi_enforce_resources=lax mem_sleep_default=deep clocksource=tsc tsc=reliable intel_idle.max_cstate=0 intel_pstate=passive apparmor=0 mitigations=off nmi_watchdog=0 pti=on numa=off iommu=memaper=4 iommu.forcedac=1 ipcmni_extend add_efi_memmap enable_mtrr_cleanup mtrr_spare_reg_nr=6 gpio-mockup.gpio_mockup_named_lines pci=noaer nvidia-drm.modeset=1 dell_wmi.modeset=1 nouveau.modeset=0 module_blacklist=nouveau noplymouth nosplash”

GRUB_CMDLINE_LINUX=“nvidia-drm.modeset=1 nouveau.modeset=0 module_blacklist=nouveau dell_wmi.modeset=1”

note: The kernel parameter apci_osi=Linux can be used in newer (late 2019 and later) Asus laptops.
It may take upto 3 clean/ safe/ slow system shutdowns for kernel parameters to take effect.

“I have nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1 acpi_backlight=native in my GRUB_CMDLINE_LINUX_DEFAULT .”
So you’ve enabled the nVidia Driver backlight handler and then enabled If set to native, use the device’s native backlight mode.

The first and last thing I would try after fixing the kernel parameters and safely power cycling the system twice so the kernel parameters take effect… would to run:

lsmod and make sure the dell_wmi module is loading at boot by setting parameters in /etc/default/grub and /etc/modprobe.d/dell_wmi.conf

maybe it looks something like :
nano /etc/default/grub


anyway. Thats my ramble. mhope it helps. good luck!