[NVIDIA Beta driver 545.23.06] Brightness not working / changing

This bug seems to had make a comeback since driver 475, where brightness could not be changed and was stuck on a low value. Now, the opposite occurs, where brightness is stuck on a high value instead.

OS: Fedora 39
Running Wayland, but also happens on X11.

1 Like

I am running Ubuntu 23.10 on an nVIDIA GeForce RTX 2060 laptop.
I just installed the New Feature Branch driver 545.29.02 from

I still use following configuration
cat /etc/default/grub
GRUB_CMDLINE_LINUX=“nvidia-drm.modeset=1 acpi_backlight=native nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1”
With driver 535.113.01 this was working fine.
With 545 I have no brightness control at all, not in Ubuntu settings, not with the keys Fn-F5/F6.
This is still with X11, I don’t use Wayland.
In the BIOS I have chosen for discrete graphics meaning only nVIDIA and not Intel.

I have experienced the same, it seems to be a regresshion, /sys/class/backlight/nvidia_0/actual_brightness contains the correct brightness value but the actual screen brightness doesn’t get changed.

Thanks for the bug report.

@amrits is there a bug filed to track the next steps?

Backlight issues frequently are specific to particular notebook system designs: @BertRAMAerts @Moody.Liu could you please provide detailed information about what notebook systems you are observing these symptoms on?

My laptop:
81Y6 Lenovo Legion 5 15IMH05H
NVIDIA GeForce RTX 2060 Mobile
Intel i7-10750H (12) @ 5.000GHz

Thanks. Some of the Legion 5 notebooks have “Advanced Optimus” and should be using the nvidia_wmi_ec_backlight driver. Do you have a /sys/class/backlight/nvidia_wmi_ec_backlight device in sysfs?

I notice that you are setting ‘acpi_backlight=native’ on your kernel command line, so perhaps you’ve already come to the determination that your system is supposed to be using the NVIDIA dGPU driver for backlight control rather than the in-tree EC backlight driver. (Some notebooks have firmware bugs where ACPI reports the wrong backlight control method, which the “acpi_backlight” option is meant to work around.)

Oops, I didn’t scroll up far enough to see the actual OP of this thread. @robotta2, same question to you: could you please provide detailed information about the notebook system you are observing the symptom on?

I have similar problem on Legion 5 Pro 16ACH6 2021 which uses NVIDIA® GeForce RTX™ 3050 Ti 4GB GDDR6

I’m using kernel linux-zen 6.5.9.zen2-1 on archlinux without extra acpi-related options

While trying to find workaround I’ve tried to change acpi_backlight kernel parameter which did not help

I’m using the following options for nvidia kernel driver:

options nvidia-drm modeset=1
options nvidia NVreg_RegistryDwords=EnableBrightnessControl=1
options nvidia NVreg_DynamicPowerManagement=0x03
options nvidia NVreg_PreserveVideoMemoryAllocations=1

I’ve switched the laptop to nvidia only mode in BIOS which disables the integrated gpu and switches the laptop screen to be connected to the nvidia gpu

bert@legion5ubuntu:/sys/class/backlight$ ls -al
total 0
drwxr-xr-x  2 root root 0 Nov  3 09:37 .
drwxr-xr-x 86 root root 0 Nov  3 09:37 ..
lrwxrwxrwx  1 root root 0 Nov  3 08:37 nvidia_0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/nvidia_0

So no /sys/class/backlight/nvidia_wmi_ec_backlight

Sure, here are my laptop specs:

Operating System: Fedora Linux 39
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.111.0
Qt Version: 5.15.10
Kernel Version: 6.5.6-300.fc39.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Memory: 15.3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1060 with Max-Q Design/PCIe/SSE2
Manufacturer: HP
Product Name: OMEN by HP Laptop 15-ce0xx

My laptop spec:

Operating System: Arch Linux
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.111.0
Qt Version: 5.15.11
Kernel Version: 6.6.0-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 32 × 13th Gen Intel® Core™ i9-13900HX
Memory: 62.6 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 4050 Laptop GPU/PCIe/SSE2
Manufacturer: LENOVO
Product Name: 82WK
System Version: Legion Y9000P IRX8

01:00.0 VGA compatible controller: NVIDIA Corporation AD107M [GeForce RTX 4050 Max-Q / Mobile] (rev a1)

Thanks, everybody. I was able to reproduce the symptom on a Lenovo Legion laptop in discrete-GPU-only mode: with a 545 driver, I can observe that the value in /sys/class/brightness/nvidia_0/brightness changes when I hit the brightness hotkeys, but the screen’s actual brightness remains unchanged. (I suspect it’s at the maximum level.) With 535, the physical brightness level changes as expected when manipulating the brightness controls. I filed NVIDIA bug #4364327 to track the issue internally.

2 Likes

I also see this regression on an Alienware 17 R4 with a 1070. Bug report attached.

I also find these in the /var/log/messages:

Nov 2 20:32:59 alice audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=‘unit=systemd-backlight@backlight:nvidia_0 comm=“systemd” exe=“/usr/lib/systemd/systemd” hostname=? addr=? terminal=? res=failed’
Nov 2 20:32:59 alice systemd[1]: Starting systemd-backlight@backlight:nvidia_0.service - Load/Save Screen Backlight Brightness of backlight:nvidia_0…
Nov 2 20:32:59 alice systemd-backlight[1020]: nvidia_0: Failed to write system ‘brightness’ attribute: Invalid argument
Nov 2 20:32:59 alice systemd[1]: systemd-backlight@backlight:nvidia_0.service: Main process exited, code=exited, status=1/FAILURE
Nov 2 20:32:59 alice systemd[1]: systemd-backlight@backlight:nvidia_0.service: Failed with result ‘exit-code’.
Nov 2 20:32:59 alice systemd[1]: Failed to start systemd-backlight@backlight:nvidia_0.service - Load/Save Screen Backlight Brightness of backlight:nvidia_0.

nvidia-bug-report.log.gz (1.4 MB)

Me too. And I suspect more will be affected, since 545 was just moved out of testing in Arch.

Operating System: Arch Linux
Device: Lenovo Legion 5 Pro
Product Name: NVIDIA GeForce RTX 3070 Ti Laptop GPU

The brightness is very glaring… I’m thinking to change to “Switchable Graphics” as a workaround though that is not optimal.
Any chance there is a workaround with NVidia? May be some obscure commandline parameters?

For what it’s worth, I am also afflicted with this, also on Arch Linux. I updated my system today and am now stuck with 100% brightness using driver 545.29.02.

Prior to that, I was able to set brightness by calling xbacklight and also having set EnableBrightnessControl=1 and "Option "Backlight" "acpi_video0" in xorg.conf. See the output of nvidia-bug-report.sh attached.

Currently, I only have one entry (symlink) /sys/class/backlight/nvidia_0, containing files brightness, actual_brightness, etc.

If I xbacklight -set 50 or xbacklight -set 10, both brightness and actual_brightness remain at 100.

I also tried replacing acpi_video0with nvidia_0, and afterwards re-running nvidia-xconfig, just to see if maybe something would change.

nvidia-bug-report.log.gz (254.5 KB)

Arch Linux
Asus GL703VM (Laptop)
NVIDIA GeForce GTX 1060

545.29.02 causes 100% brightness. Downgrading to 535.113.01 resolves the issue.

Falling back to hybrid graphics is not an option on this laptop. As in the firmware doesn’t even provide the option.

Applying the patch from The brightness control of NVIDIA seems to be broken · Issue #573 · NVIDIA/open-gpu-kernel-modules · GitHub fixes the issue.

1 Like

Having a similar issue on an HP OMEN Laptop 15-ek018ca running Arch Linux though the brightness is stuck at 50% instead of 100%. Unsure if it’s the same issue, but it did start after upgrading to 545.23.06 and persists on 545.29.02-4

To confirm in case somebody else looks at this thread due to a similar issue, this was fixed with 545.29.06-1 as packaged on arch linux at least for myself

No changes were made to configuration on my end

2 Likes