Brightness on a Lenovo ThinkPad P52 no longer controllable after updating nvidia-drivers to 525.xx series

I’m unable to change the brightness of my screen after updating to nvidia-drivers-525.60.11. I’ve tried a similar driver in the 525.xx series earlier, but it caused crashes. It works fine using the 515.xx series driver. I’ve filed a relevant bug report at the distro, but am not sure whether I should file it here or at the distribution.


nvidia-bug-report.log.gz (796.9 KB)

I am using Ubuntu 22.10 on a Lenovo Legion 5 laptop with GeForce RTX 2060. I have the same problem that when Ubuntu boots, the normally saved “half” brightness is not applied: the screen starts with 100% brightness. This started after using the 525.60.11 driver. But I can still adapt the brightness with the slider of the settings. But it acts strangely: in the first 10% of the slider the real range of low to full brightness is present and the other 90% of the slider is normal behaviour from low to high brightness. But my /etc/default/grub contains
GRUB_CMDLINE_LINUX="nvidia-drm.modeset=1 acpi_backlight=native nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1"
And I have selected discrete graphics in the BIOS.

Same issue on my Lenovo L340 Gaming with a GTX 1050 3GB Max-Q. I had to revert back to the 515 driver
I am also using Ubuntu 22.10

I see same behavior on Lenovo X1 Extreme Gen. 2, NVIDIA Corporation TU117M [GeForce GTX 1650 Ti Mobile] (rev a1).
Driver version 525.60.11-2
OS: Arch Linux

If I move to nvidia-open package (525.60.11-2) brightness kinda works. Why kinda: there’re several ranges of brigntess increase. From 0 to 11, from 24 to 100. Values 0 and 24 gives minimal actual brightness.

Is it a coincidence that all complaints on brightness happen on Lenovo laptops?
With latest driver 525.78.01 I still have same issue of 2 brightness ranges in the slider bar.

Hi All,
Thanks for reporting issue to us.
Just for isolation purpose, can you please perform suspend/resume operation once and then try to change brightness to see if it works or not.

Dear amrits,
So I have Lenovo Legion 5 laptop with GeForce RTX 2060 and driver 525.78.01 on Ubuntu 22.10. For me both after booting and also after resume from suspend, I can change the brightness. But the brightness slider has 2 regions going from low to high brightness. Let’s say the first 10% of the slider goes from low to high. And then from 10% to 100% slider, it again goes from low to high. And the correct brightness from before the boot somewhere around 55% of the slider is not kept. I always after boot have to manually set the brightness to desired value from the value after boot which is about 10% of slider at full brightness.

1 Like

After suspend/resume, brightness controls do indeed resume function. Running 525.89 proprietary driver on kernel 6.1.12, openSUSE Tumbleweed on Lenovo P15 Gen2

I have a similar issue with a Lenovo P1 with an A2000 running Debian testing Nvidia driver 525.85.12 with KDE.

The brightness goes from dim to full brightness in three steps 0%, 5%, 10%.
It the gets dim at 15% and works normally to 100%.

On initial boot it works for a bit and then goes to 100% brightness and gets stuck there.

A suspend resume cycle fixes the 100% brightness being stuck.

I have exactly the same error. After updating my laptops GPU driver (Lenovo ThinkPad P53, Nvidia Quadro RTX 4000, Ubuntu 22.04, Kernel 6.2.6-060206-generic x86_64) to 525.85.12 brightness control stop working. Suspend/resume makes it working again, but it is broken now:

$ > cat /sys/class/backlight/nvidia_0/max_brightness

$ > echo 10 > /sys/class/backlight/nvidia_0/brightness - gives high brightness
$ > echo 11 > /sys/class/backlight/nvidia_0/brightness - gives minimum brightness
$ > echo 99 > /sys/class/backlight/nvidia_0/brightness - gives high brightness
$ > echo 100 > /sys/class/backlight/nvidia_0/brightness - gives low brightness

I have the same issue with nvidia 525.89.02 for kernel 6.2.6-76060206-generic, Pop!_OS 22.04 LTS x86_64 on ThinkPad P15 Gen 1. It works fine with nvidia-driver-515. There is not workaround to fix it. Hope Nvidia should fix it soon!!

Another P52 and on both 525 and 530 drivers brightness is not working. Suspend and resume does make it work somewhat (until reboot), but it’s buggy.

Haven’t been able to find a workaround yet.

We have a bug 4029460 filed internally for tracking purpose.
Shall keep updated on the debug progress.

I am experiencing the other way round with an Thinkpad P1 Gen2 running KDE Plasma X11:

latest tested Driver version: 530.51.03

after some sleep/wake cycles brightness sets to maximum brightness level.
KDE Plasma (X11) says minimum brigtness level, while

cat /sys/class/backlight/intel_backlight/brightness



which is maximum brightness.

Trying to reduce or increase brightness by one step via FN + F6 jumps to brightness level 0 or 20

I was able to work around the problem for now by switching from the Dedicated Graphics in the BIOS / UEFI settings to Hybrid Graphics (as a P52 has a MUX chip). After changing this setting, the backlight is working again (because then it’s controlled via the i915 graphics chip, as only external monitors are controlled via the nvidia graphics chip)

I have my P1 Gen2 in hybrid graphics.

I am experiencing brightness control issues after several sleep cycles with Nvidia driver.
No issues with nouveau driver.

Hello, attaching similar issue with brightness settings, although on my device you can change it. Link to thread - Screen Brightness Resets to 100% after reboot

Please verify the fix with latest released driver 525.116.03 and share test results.

How can 525.116.03 be the latest version when I am on nvidia-open-dkms@530.41.03-9? :thinking:

This issue is not yet fixed on nvidia-open-dkms@530.41.03-9; tested on Lenovo P15 Gen1 with NVIDIA Quadro T1000 Mobile on Arch Linux.