Ubuntu 22.04 - Flickering screen and Brightness not working on Dell G15 RTX 3060

I have a Dell G15 with a Nvidia GeForce RTX 3060 Mobile graphic card. Just installed ubuntu 22.04 alongside with Windows, but I have two main problems:

  • Screen flickers randomly.
  • Brightness controls doesn’t work, either keyboard and in the OS. Specifically when turning brightness up/down, there is no effect (brightness is stuck at max).

Here’s my nvidia-smi output:

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 515.48.07    Driver Version: 515.48.07    CUDA Version: 11.7     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   40C    P0    N/A /  N/A |      5MiB /  6144MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A      1507      G   /usr/lib/xorg/Xorg                  4MiB |
+-----------------------------------------------------------------------------+

My ubuntu-drivers devices output

== /sys/devices/pci0000:00/0000:00:01.1/0000:01:00.0 ==
modalias : pci:v000010DEd00002560sv00001028sd00000B5Ebc03sc00i00
vendor   : NVIDIA Corporation
model    : GA106M [GeForce RTX 3060 Mobile / Max-Q]
driver   : nvidia-driver-470-server - distro non-free
driver   : nvidia-driver-510-server - distro non-free
driver   : nvidia-driver-515-server - distro non-free
driver   : nvidia-driver-510 - distro non-free
driver   : nvidia-driver-470 - distro non-free
driver   : nvidia-driver-515 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

And the output of sudo lspci -k | grep -EA3 'VGA|3D|Display'

pcilib: Error reading /sys/bus/pci/devices/0000:00:08.3/label: Operation not permitted
01:00.0 VGA compatible controller: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] (rev a1)
	Subsystem: Dell GA106M [GeForce RTX 3060 Mobile / Max-Q]
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
--
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Rembrandt (rev c8)
	Subsystem: Dell Device 0b5e
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

*Already tried changing the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=linux"

also to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=legacy"

and then always

sudo update-grub

Also when typing dmesg, I get a [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership

Finally, I installed liquorix kernel as suggested in this thread - current version is 5.15.0-43-generic

But no luck at all.
Any help would be much appreciated!

nvidia-bug-report.log (2.2 MB)

The display is driven by the amd gpu. Since the 6800H was released in january, please use the liquorix ppa to upgrade to kernel 5.18.

1 Like

Thanks for your reply! That seems to have fixed the flickering, but I still cannot control brightness.

My relevant lines in /etc/default/grub


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=legacy"
GRUB_CMDLINE_LINUX="acpi_backlight=legacy"

nvidia-bug-report.log (281.0 KB)

Please remove

acpi_backlight=legacy

and check again. If it still doesn’t work, please post the output of
ls /sys/class/backlight

1 Like

Changed to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

…but stil not working. Output is

amdgpu_bl0 nvidia_wmi_ec_backlight

Same old problem, amdgpu_bl0 is the correct backlight but gnome is using nvidia_wmi_ec_backlight which shouldn’t be there at all.
Please check if a bios update is available.

1 Like

I’m afraid I have the latest version G15 5525 - version 1.3.7, so I will try to see if I can report them somehow. Thanks for the help anyway!