Brightness control (still) not working since 465

Hello. I am having issues with brightness control under X with my NVIDIA GPU.

I first stumbled upon this issue two years ago and have been tracking it in this other closed post; since then I’ve been holding off updating my system, using the last NVIDIA driver that worked (465). Since the post was closed and I couldn’t see more references to the issue I thought that maybe it had been fixed… Maybe, but not for me.

Premises:

  • Clevo P7xxTM1 laptop
  • BIOS Version 1.07.20
  • EC firmware version 1.07.12
  • Arch linux, fully updated (Linux nadja 6.1.1-arch1-1 #1 SMP PREEMPT_DYNAMIC Wed, 21 Dec 2022 22:27:55 +0000 x86_64 GNU/Linux)
  • NVIDIA Geforce GTX 1060
  • systemd-boot (not sure if relevant)
  • Qtile (X11) window manager

What happens:
Up until the login screen, before starting X11, everything works. I have /sys/class/backlight/acpi_video0/ and can write to the corresponding brightness file to change the backlight. It works.
When I start Qtile a new contender appears under /sys/class/backlight/nvidia_0, but the screen brightness is stuck at 100%. I can change it manually or by third party tools like xbacklight or brightnessctl and the content of brightness changes accordingly, but the light doesn’t fade.

Relevant reports:
ls.txt (170 Bytes)
inxi.txt (2.3 KB)
acpidump.txt (868.4 KB)
nvidia-bug-report.log.gz (597.8 KB)

I could attempt to update the BIOS to the latest available version, but since my Windows partition doesn’t share the issue one would think that’s not the core of the problem.

also Brightness on a Lenovo ThinkPad P52 no longer controllable after updating nvidia-drivers to 525.xx series - #4 by lucasm_27

I have the same problem:
Kernel 6.1.2-arch1-1
Using Grub
on 6.1.2-arch1-1

Tried all of the above changes nothing seems to work.
Quirk:

❯ ls /sys/class/backlight
amdgpu_bl0

This used to also have a nvidia_wmi_ec_backlight, which is apparently a kernel module and was the primary way i controlled brightness. I can confirm this module appears in the output of lsmod but the backlight class does not appear.