Backlight brightness control not working on Lenovo Legion 5 Pro (16ACH6H)

I am using Fedora 33 on a Legion 5 Pro laptop featuring a RTX 3070 GPU, and backlight brightness control isn’t working at all. Methods that I have tried include

  • Fn keys (OSD comes up, but no further effect)
  • xbacklight -set X (no effect)
  • nvidia-settings -n -a BacklightBrightness=X (no effect)

This is the case for both the 460.67 and 465.24 drivers. FWIW, brightness control is working when using the iGPU (using amdgpu driver) instead of the dGPU, but in that case the external monitor doesn’t work because the nvidia driver can’t be used as output sink for amdgpu.

I have attached a bug report log, which also shows my various attempts to hack around the problem (different acpi.video= kernel parameters, using a self-built 5.12 kernel in the hopes nouveau would work sufficiently etc.), but the currently running config should be sane (distro kernel, no special kernel parameters).

Does anyone have any suggestions and/or can confirm this is an issue in the driver?

nvidia-bug-report.log.gz (404.5 KB)

1 Like

I have the same problem on ubuntu 20.04, here is a list of things I have tried so far Legion 5 pro brightness control doesn't work on ubuntu 20.04 with nvidia driver 460 - Ask Ubuntu

Edit: Didn’t notice before that it was working for you in hybrid mode, for those who absolutely need brightness working, Install mainline kernel 5.11.16 and then restart with hybrid mode and use this line in grub (then update grub and restart again):

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash amdgpu.backlight=0”

In discrete mode, as OP mentioned brightness control still doesn’t work.