Backlight control not working on Eurocom Sky X7E2 (Clevo P775DM3) with GTX 1080

Hello,

I’ve bought a new laptop with GTX 1080. Unfortunately I’am unable to get backlight control working. In default state, brightness keys seems to work (I can see ACPI events, brightness bar on screen changes), but it has no real effect on display backlight. Xbacklight does not work as well (I’ve found some threads about backlight here, but xbacklight is working there. This is not my case).

I have tried various acpi kernel parameters, the only result was that even brightness controlling keys stopped working.

I have tried to install nvidiabl module from here: https://github.com/madsherlock/nvidiabl but it has no support for Pascal cards and I don’t know how to add it properly.

I’am using Nvidia 387.34 driver with Ubuntu 17.10, but it was the same with Ubuntu default driver.
nvidia-bug-report.log.gz (140 KB)

UPDATE> Found NVreg_EnableBacklightHandler kernel parameter, tried to set it to 1, but it does not help :(

Further investigation: I have /sys/class/backlight/acpi_video0 directory. Device metioned there is a nVidia card (cat device/vendor there says 0x10de). It reports max_brightness as 100. I can write to brightness and read changed result from actual_brightness. But no action has any effect on real backlight brightness.

I have the exact same problem with my laptop and its GTX 1060. In my case xbacklight works. But I’d love to have proper “/sys/class/backlight” support. I also tried multiple acpi_osi and acpi_backlight values. Most recently I have tried to add nvidia.NVreg_EnableBacklightHandle=1 and it still doesn’t work.

Has anyone EVER been able to get brightness to work on a G-SYNC enabled Pascal-based laptop (without Optimus)? I have yet to find a success story! I regret more and more my purchase because back then I didn’t know that G-SYNC meant that the Intel card would be disabled. I don’t need the dGPU on Linux, so I’d much rather use the Intel GPU. I’m sure that things would work much better if the Intel GPU would be the one driving the display output, backlight control, etc.

My problem with backlight was solved by upgrading LCD panel firmware. And probably BIOS upgrade which I have done first. Look here: https://devtalk.nvidia.com/default/topic/942337/backlight-brightness-not-hooked-to-acpi-events-ubuntu-16-04-/ I have written a post there and forgot to mention it in my own thread :-/

So, you should contact you laptop manufacturer for a new LCD panel firmware (upgrading only BIOS was not sufficient in my case).

And, as we speak, I have also problem with Nvidia driver and games: https://devtalk.nvidia.com/default/topic/1030326/gpu-fallen-off-the-bus-while-running-more-demanding-demos-or-games/. May I ask you, if you have tried any games with your laptop and noticed any problems similar to mine?

Thanks for the reply. I’ll read the topic you mentioned to see if there’s something there that can help me. But if the only fix possible is ASUS issuing a firmware upgrade to fix my issue on my GL502VM, I’m not too confident about that.

However, as I said above, I can use xbacklight but it is far from ideal because it doesn’t work on Wayland. It is true that right now the NVIDIA proprietary drivers only work with X.Org, but if they ever move on to Wayland and there’s no way to change brightness it will be awful.

I also don’t have ANY WAY backlight control with the open source (nouveau) drivers, both on X.Org and Wayland. In fact, I’d be happy to use the nouveau drivers if it wasn’t for that. I don’t need my GPU full power while on Linux as long as basic 3D acceleration for the desktop works well (and it does).

Regarding the other problem you’re facing, I have yet to notice anything like it. But I very rarely play games on my Linux install (currently Ubuntu 17.10 with the latest NVIDIA drivers installed through this PPA: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa). I have Windows for that ;) But I do have Steam installed, so I may try to run a couple of games to check if they perform with no issues.

My backlight control didn’t worked even in Windows. So it was probably another problem. You can also try this page: https://wiki.archlinux.org/index.php/backlight from Archlinux wiki.

As for that “Fallen of the bus” problem, I haven’t ever tried Nouveau because I need GPU power under Linux. Mostly for rendering (no problem there), but I want to play some games occasionally. I can reproduce the problem with 100% probability with Total war: Warhammer, it freezes after several tens of seconds of gameplay. I bought it on Steam as well, but I don’t know, if I can borrow you that game somehow? I don’t play much and I don’t know all Steam abilities.