bug: yellow background color for kernel code missing

Hi,
I noticed, that yellow background color for kernel code in editor (nsight) is missing, if there is following statement in code:

#include <cuda_runtime_api.h>

This bug happen to be in nsight 7.5 and nsight 8.0
Everything is OK in nsight 7.0
I am always using Ubuntu and run installer.
Is there any solutions for this problem?

Best regards, Andrej

I have reproduced the issue and filed a bug to our dev.
Thanks for reporting.

Hi

is there any news about solving this bug? Thank you and best regards, Andrej

Hi
I found workaround for this problem. The problem is in indexer in Nsight. The solution (not pretty nice, but it works) is:

In file /usr/local/cuda/include/host_defines.h in line 185 add:

#if ( !defined(MY_INDEXER) )

in line 198 add:

#endif /* !defined(MY_INDEXER) */

You will get all together:
#if ( !defined(MY_INDEXER) )
#define host
location(host)
#define device
location(device)
#define global
location(global)
#define shared
location(shared)
#define constant
location(constant)
#define managed
location(managed)
#endif /* !defined(MY_INDEXER) */

Now you have to set symbol MY_INDEXER in Nsight:

Project/Properties/C/C++General/Preprocessor Include Paths, Macros etc./Entries/CUDA C/CDT User Settings Entries

klick button: Add

pull down: Preprocessor Macro
Name: MY_INDEXER
Value: 1

klick button: OK
Klick button: Apply
klick button: OK

Project/C/C++ Index/Rebuild