Build OpenCV 4.6.0 with Cuda on Jetson Nano

Hi everybody!
I am going to build opencv 4.6.0 with cuda on jetson nano 4G evaluation board.
I try all these ways:

But unfortunately all the ways result in same error like this:

c++: internal compiler error: Segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-7/README.Bugs> for instructions.
modules/sfm/src/libmv/libmv/multiview/CMakeFiles/multiview.dir/build.make:86: recipe for target 'modules/sfm/src/libmv/libmv/multiview/CMakeFiles/multiview.dir/' failed
make[2]: *** [modules/sfm/src/libmv/libmv/multiview/CMakeFiles/multiview.dir/] Error 4
CMakeFiles/Makefile2:6506: recipe for target 'modules/sfm/src/libmv/libmv/multiview/CMakeFiles/multiview.dir/all' failed
make[1]: *** [modules/sfm/src/libmv/libmv/multiview/CMakeFiles/multiview.dir/all] Error 2
Makefile:162: recipe for target 'all' failed
make: *** [all] Error 2

I have paid attention to following tips:

  • I create about 10G swap.
  • I use different nano fresh images.
  • I try different version of opencv and just 4.1.1. is build successfull, any other version leads to the same error.

Does anybody do these before? Any solution?

Thanks in advance for any help.


You can try our sample for Nano.
Just change the version to 4.6.0 and it should work.



Hi dear AastaLLL
Yes it works!
Thanks for your reply.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.