Building tensorrt for python 3.9.14 broke my package links

uname -a output:

4.9.253-tegra #1 SMP PREEMPT Mon Jul 26 12:19:28 PDT 2021 aarch64 aarch64 aarch64 GNU/Linux

I am trying to get some vision programs up and running on my Jetson Xavier NX16

I needed to install nvidia-tensorrt, but it wasn’t available from pip for arch64, so I found this: Tensorrt on Jetson with python 3.9 - #9 by AastaLLL

I already had python3.9.14 up and running, so I found the download link for python3.9.14 instead of 3.9.1 and followed the instructions.
After building and installing nvidia-tensorrt I tried running my script, which worked before, but now I am met by errors saying that modules can not be found even though they are clearly present in my python folder.

~.local/lib/python3.9/site-packages/tifffile/", line 840, in

import _imagecodecs as imagecodecs ModuleNotFoundError: No module named ‘_imagecodecs’

I used

sudo find / -name '*imagecodecs*'

And found



I think that the make altinstall step broke my python3.9.14 paths in some way, but I am not sure how.


Do you install tifffile with python 3.9.1?
If yes, would you mind reinstalling it again with python3.9.14 to see if it works?


Hi @AastaLLL

The problem is that I installed python3.9.14 instead of 3.9.1 to make sure that the wheel would work with 3.9.14, I have tried reinstalling tifffile, but it still does not work.


Have you tried to install the missing library directly?

For example:

$ pip3 install imagecodecs


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.