Can not install cuda-10.2, please help, thank you

I struggle half day to install cuda-10.2
I search but don’t know how to uninstall cuda-8.0



May be
sudo yum -y install nvidia-driver-latest-dkms cuda

should be

sudo yum -y install nvidia-driver-latest-dkms cuda-10-2

The last step sudo yum -y install cuda-drivers fail:

Resolving Dependencies
--> Running transaction check
---> Package cuda-drivers.x86_64 0:390.46-1 will be installed
--> Processing Dependency: xorg-x11-drv-nvidia-libs(x86-64) >= 1:390.46 for package: cuda-drivers-390.46-1.x86_64
--> Processing Dependency: xorg-x11-drv-nvidia-gl(x86-64) >= 1:390.46 for package: cuda-drivers-390.46-1.x86_64
--> Processing Dependency: xorg-x11-drv-nvidia-devel(x86-64) >= 1:390.46 for package: cuda-drivers-390.46-1.x86_64
--> Processing Dependency: xorg-x11-drv-nvidia >= 1:390.46 for package: cuda-drivers-390.46-1.x86_64
--> Running transaction check
---> Package xorg-x11-drv-nvidia.x86_64 1:390.46-1.el7 will be installed
---> Package xorg-x11-drv-nvidia-devel.x86_64 1:390.46-1.el7 will be installed
---> Package xorg-x11-drv-nvidia-gl.x86_64 1:390.46-1.el7 will be installed
---> Package xorg-x11-drv-nvidia-libs.x86_64 1:390.46-1.el7 will be installed
--> Processing Conflict: 3:nvidia-driver-latest-dkms-devel-440.33.01-1.el7.x86_64 conflicts xorg-x11-drv-nvidia-devel
--> Processing Conflict: 3:nvidia-driver-latest-dkms-440.33.01-1.el7.x86_64 conflicts xorg-x11-drv-nvidia
--> Processing Conflict: 3:nvidia-driver-latest-dkms-libs-440.33.01-1.el7.x86_64 conflicts xorg-x11-drv-nvidia-gl
--> Processing Conflict: 3:nvidia-driver-latest-dkms-libs-440.33.01-1.el7.x86_64 conflicts xorg-x11-drv-nvidia-libs
--> Finished Dependency Resolution
Error: nvidia-driver-latest-dkms conflicts with 1:xorg-x11-drv-nvidia-390.46-1.el7.x86_64
Error: nvidia-driver-latest-dkms-libs conflicts with 1:xorg-x11-drv-nvidia-libs-390.46-1.el7.x86_64
Error: nvidia-driver-latest-dkms-libs conflicts with 1:xorg-x11-drv-nvidia-gl-390.46-1.el7.x86_64
Error: nvidia-driver-latest-dkms-devel conflicts with 1:xorg-x11-drv-nvidia-devel-390.46-1.el7.x86_64
 You could try using --skip-broken to work around the problem
** Found 13 pre-existing rpmdb problem(s), 'yum check' output follows:
cuda-core-8-0-8.0.61-1.x86_64 has missing requires of cuda-misc-headers-8-0
cuda-cudart-dev-8-0-8.0.61-1.x86_64 has missing requires of cuda-cudart-8-0 >= ('0', '8.0.61', None)
cuda-cudart-dev-8-0-8.0.61-1.x86_64 has missing requires of cuda-driver-dev-8-0
cuda-cusparse-dev-8-0-8.0.61-1.x86_64 has missing requires of cuda-cusparse-8-0 >= ('0', '8.0.61', None)
cuda-npp-dev-8-0-8.0.61-1.x86_64 has missing requires of cuda-npp-8-0 >= ('0', '8.0.61', None)
cuda-nvgraph-dev-8-0-8.0.61-1.x86_64 has missing requires of cuda-nvgraph-8-0 >= ('0', '8.0.61', None)
cuda-samples-8-0-8.0.61-1.x86_64 has missing requires of cuda-cublas-dev-8-0
cuda-samples-8-0-8.0.61-1.x86_64 has missing requires of cuda-driver-dev-8-0
cuda-toolkit-8-0-8.0.61-1.x86_64 has missing requires of cuda-cublas-dev-8-0 >= ('0', '8.0.61', None)
cuda-toolkit-8-0-8.0.61-1.x86_64 has missing requires of cuda-driver-dev-8-0 >= ('0', '8.0.61', None)
cuda-toolkit-8-0-8.0.61-1.x86_64 has missing requires of cuda-misc-headers-8-0 >= ('0', '8.0.61', None)
cuda-visual-tools-8-0-8.0.61-1.x86_64 has missing requires of cuda-cublas-dev-8-0
cuda-visual-tools-8-0-8.0.61-1.x86_64 has missing requires of cuda-driver-dev-8-0