problem with sdk 1.1 in opensuse 10.2

I have a big problem with CUDA.
I am SO openSUSE 10.2
Tesla C780
When I do:
Exit = “”

Rpm-qa | grep nvidia:
Exit =
NVidia gfxG01-kmp-default-169.09_2.6.18.8_0.8-0.2
X11-video nvidiaG01-169.09-0.1

When you install the toolkit 1.1 of CUDA and test as an example matrixMul departure is: “There is no device for supporting CUDA”

I do not understand.
In addition, before I had installed version 1.0 and I worked.
Now I try to install the 1.0 and I get the following error:
Error: API mismatch: the NVIDIA kernel module has version 169.09,
NVIDIA driver but this component has 100.14.11 version. Please make
Sure that the kernel module and all NVIDIA driver components
Have the same version.
There is no device supporting CUDA "

It seems that something has changed in version 1.0 installers because sooner if it worked.

I reinstalled the operating system and pasándo remains the same.

Please, if anyone can help I would appreciate it very much.
If someone has the former installer of 1.0 toolkit of CUDA work, please, let me it.

Pardon my English, but I am learning the language.
Thank you. :(

I was hard, but I got.
There had installed the driver version correct.
As I have opensuse, I installed with YaST and I installed an incorrect version.
Hand install is the Solution
I had a problem with the kernel-sources because it also installed with YaST.
Download rpm package of kernel-source of the same version that your kernel and install it manually with rpm -ivh. "

You can definitively use YaST2 for installing the drivers… You have to include the nvidia-repository and install the appropriate packages. In your case I assume you installed “nvidia-gfx” instead of “nvidia-gfxG01”?