OpenSUSE10.2: NVidia Driver Installation Question openSUSE 10.2-IA32

I tried following the http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html linked to by the CUDA site.

I got through the YAST installation successfully i think. (I double-checked by running nvidia-settings and found the driver version to be 173.14.05).
I wasn’t sure what they meant by “Use “sax2 -r” for X.Org configuration.” so I skipped that part…could somebody walk me through it?

When I tried running some CUDA code, I got the following error:
Error: API mismatch: the NVIDIA kernel module has version 173.14.05,
but this NVIDIA driver component has version 100.14.11. Please make
sure that the kernel module and all NVIDIA driver components
have the same version.

What’s the difference between the kernel module and the driver component?

Any feedback would be much appreciated,

Thank you,

Bob

The NVIDIA driver has two components. The nvida.ko kernel module, and the device driver (one for X, and one for CUDA). Both components must have the same version.

You should contact SUSE to resolve this problem, as their driver package/upgrade mechanism is apparently not working correctly.

I was able to find a copy of NVIDIA-Linux-x86_64-173.14.09-pkg2.run by googling and attempted to install it by hand, that seemed to work. (The CUDA website seems to be somewhat broken, I can only download build 169 using the download interface. Also, it won’t let me download CUDA 1.0 when I select Linux as my operating system, only 1.1.)

However, it seems like when I upgraded the CUDA toolkit, it removed libcuda.so and never replaced it with a new one. Now, when I try to compile, it complains about “cannot find -lcuda”. I tried installing both the 32bit version and 64bit version of CUDA toolkit but neither version has that library. They do have libcudart.so, which is why -lcudart works.

How can I get libcuda.so?

Thank you.

Seems like I just had to install the CUDA 2.0 version of the NVIDIA display drivers.

Everything seems to work now…you can close this thread :)