API mismatch with 32-bit cuda 1.0

I just installed the latest 32-bit linux driver and the toolkit for SUSE Linux Enterprise Desktop 10

When I run any cuda stuff I get the following in my logs:

[42952490.010000] NVRM: API mismatch: the client has the version 100.14.10, but

[42952490.010000] NVRM: this kernel module has the version 100.14.11.  Please

[42952490.010000] NVRM: make sure that this kernel module and all NVIDIA driver

[42952490.010000] NVRM: components have the same version.

I tried the toolkit for OpenSUSE 10.1 and 10.2 with the same results.

What does this mean?

Which Linux distribution are you running?

I am using Ubuntu feisty (7.04)

I get the same error (Running CUDA Toolkit version 1.0 for Redhat Enterprise Linux 4.x on 32-bit Redhat Enterprise Linux 4 update 3).

I’d suggest downloading the package again. There may have been problems with the originally posted 1.0 packages.