NVIDIA kernel module and driver version looking for NVIDIA kernel module version 295.41

I installed devdriver_4.2_linux_64_295.41.run and
cudatoolkit_4.2.9_linux_64_ubuntu11.04.run on Ubuntu 12.04 Desktop version.
When I run nvidia-smi, I get the following message.

$ nvidia-smi
Error: API mismatch: the NVIDIA kernel module has version 295.40,
but this NVIDIA driver component has version 295.41. Please make
sure that the kernel module and all NVIDIA driver components
have the same version.
Failed to initialize NVML: Unknown Error

Where can I find the NVIDIA kernel module has version 295.41?

Thanks,

It should come with the driver.

You probably had a different kernel running at the time of your last driver update, so that your currently running kernel didn’t get the latest NVIDIA kernel module installed. Try reinstalling the driver.

Thank you for your reply.
I reinstalled the driver.
But still nvidia-smi shows the same message.
What I did are:
apt-get update
apt-get dist-upgrade
reboot
./devdriver_4.2_linux_64_295.41.run
reboot

Ubuntu 12.04 was cleanly installed and additional software is only g++.
Currently, I’m stuck.

Hi aiueo,

295.41 kernel module ships inside of the nvidia driver package.
I’ve just installed http://developer.download.nvidia.com/compute/cuda/4_2/rel/drivers/devdriver_4.2_linux_64_295.41.run on my fedora system and I couldn’t reproduce the problem.
It looks like your previous driver wasn’t uninstalled compleatly and the new driver installation has some issues.

nvidia-current-updates-dev on ubuntu website http://packages.ubuntu.com/precise/nvidia-current-updates-dev is at 295.40 version which matches the error message in your first post.
Please first try to remove the “nvidia-current-updates-dev” (or any other package with similar name) from your system and try to install the driver from CUDA zone again.

Hope this helps,
Przemyslaw Zych

Thank you very much for your suggestion.
nvidia-current-updates-dev was not installed in my system.
But nvidia-current existed.
So, I uninstalled it with ‘sudo apt-get remove nvidia-current’ and then reinstalled the driver.
It worked!
Thanks again.