Can not successfully use nsight compute on Jetson AGX Xavier

I could not find the nsight compute in the cuda folder, I could only find nvprof and nsys. So I have 2 questions:

  1. How can I get nsight compute on Jetson AGX Xavier? From jetpack( but I did not see) or installed by myself? If I must install it, which version should I choose?
  2. Can I use nv-nsight-cu-cli to locally profile a program on Jetson AGX Xavier, or I must remote profile from host? I have installed the latest nsight compute on the Xavier, but it did not successfully work. I have also tried to profile from host, but I get a similar error.


Please install it on a desktop environment and apply the remote profiling.

Thank you for your reply!
I have installed nsight compute 2022.2 on my x86 linux host and I tried remote profiling, but I got the same error like this:

I’m using the root authority to profile.

Hi, have you profiled your app on Jetson AGX Xavier with nsight compute successfully?
I met some errors and I want to know how to confirm the version of nsight compute. My cuda is 10.2 and I tried to installed nsight compute (2019.5.0) according to the cuda version, however there is no version for Jetson.
Then I installed the version(2021.2.2) and I got the following errors:

==ERROR== Failed to prepare kernel for profiling
==ERROR== Failed to profile kernel “copyPackedKernel” in process 22220
==PROF== Received signal
==PROF== Trying to shutdown target application
==ERROR== An error occurred while trying to profile.
==WARNING== No kernels were profiled.

Hi, I haven’t successfully profiled, I have tried for days. Is the version of nsight compute important for a successful profiling? I installed the latest version directly.
By the way, I just noticed that the picture I uploaded was the result on Orin platform, but I got the same error on Jetson AGX Xavier platform.

Hi, did you installed the version of ArmServer? And if the latest version can use the GUI?

I have tried installing armserver version on Xavier (but did not work), but AastaLLL Can not successfully use nsight compute on Jetson AGX Xavier - #3 by AastaLLL just said that remote profiling was needed. So I installed the x86 linux version on the host PC.

Did he mean we can only apply the remote profile and It’s not support for host profile on Jetson AGX Xavier?

I think so… But my remote profiling also failed…

It’s so difficult… I have also tried 3 days. Can I have your Wechat ? Then we can talk about it.

(Xavier NX - Nsight Compute "Failing to prepare kernel for profiling" - #17 by AastaLLL)

From this solution, he recommended to reinstall the nsight compute.

1 Like

It works! Thank you!!!

hhh, could you share me about how to deal with this problems? I want to profile the GPU utilization of my APP.


Please noted that you will need to log in as root to get access to CUDA profiling.
Below is a comment about how to set up the root password for your reference:


Hi, jasonwu_www, Sorry for getting back to you late.
I install cuda toolkit, nsight system and nsight graphics using sdk manager on a linux x86 machine.
Then I startup nsight compute from /usr/local/cuda-10.2/bin/nv-nsight-cu and use root ssh login and remote profile, you may refer to the response by AastaLLL just now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.