No timeline for profiler Xavier: nvvp and nsight compute is not working in Jetson Xavier

Profiler is not running on Jetson Xavier. I tried with nvvp and nsight compute but no timeline.

I would like to mention that I Have tested it with the CUDA Samples. Same timeline is not created.

Hi,

Currently, profiling tool requires root authority.
Please check if you have enabled the correct authority.

Thanks.

Thank you for the reply.

I want to use nvdia visual profiler remotely using ssh. How can I call Xavier sudo nvprof? or Is it possible to make some changes in xavier that will allow me to use visual profiler?

Hi,

This requires some steps. You can find some information on this topic:
https://devtalk.nvidia.com/default/topic/1049619/jetson-tx2/debugging-cross-compiled-cuda-sample-does-not-work-/

Thanks.

Hi,

Thank you for the support.

I need ssh root but I can not get it. I tried with password ubuntu but it is not working.

I tried by changes mentioned below

sudo nano /etc/ssh/sshd_config

PermitRootLogin without-password
PermitRootLogin yes

than I did
sudo service ssh restart

but still it is not possible to login as root.

I also try to follow the link you share but it is not the same as my problem.

Could you please give me a solution that will allow me to use profiler.

Thanks

Hi,

Have you setup the root password first?

The process should like this:

1.Setup root password

$ sudo passwd root

2.Edit /etc/ssh/sshd_config

diff --git a/sshd_config b/sshd_config
index a32dc1d..d21cacd 100644
--- a/sshd_config
+++ b/sshd_config
@@ -30,6 +30,7 @@
 
 #LoginGraceTime 2m
 #PermitRootLogin prohibit-password
+PermitRootLogin yes
 #StrictModes yes
 #MaxAuthTries 6
 #MaxSessions 10
@@ -54,7 +55,7 @@
 
 # To disable tunneled clear text passwords, change to no here!
 #PasswordAuthentication yes
-#PermitEmptyPasswords no
+PermitEmptyPasswords no
 
 # Change to yes to enable challenge-response passwords (beware issues with
 # some PAM modules and threads)

3. Roboot

$ sudo reboot

Thanks.

Thank you very much. It is working.

Hi,

I have same problems, and I followed this instructions.

But it still doesn’t work for my TX2 from remote.

Also, I can’t simply debug a cuda sample code (Boxfilter).

Every time when debugger hit a cuda function it turns out hanging right there.

I’ve done cross-compile settings and set root authority, but the problems are still there.

Is there any solutions or missing things to do for successfully debugging and profiling?

Thanks!