Cannot allocate memory in static TLS block

Having been working on jetracer, things going pretty smoothly. However, I decided to try some reinforcement learning rather than the base jetracer setup, and found this git.

Installed it, had to fight with it, got it kind of working, then went on vacation for a week. Now I’ve come back and I’m getting this error. I had been getting it before, but importing cv2 before torch or torch vision had caused it to disappear, this is no longer working. I looked around online about the error and most suggested adding “export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/” to .bashrc, I have done this and attempted to refresh it with “source ~/.bashrc” and it also hasn’t worked. I also attempted to add the LD_PRELOAD statement to the Jupyter notebook config file to no effect either. Tried importing os and sending the command using os.system, no effect either
I also had a strange error where during one session I lost the ability to save files, giving me an “”_xsrf" argument missing from POST" error, however, this disappeared on power cycling.
Pulling my hair out at this point, now sure what to do.

We don’t have answer, may other developers help to share expereicnes. or you can try to contact with the author to see if can have some suggestions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.