Cv2: Cannot allocate memory in static TLS block

Hi,

I tried to find out which version of some things i installed.

And by doing this the error shown in the picture occured.
In another topic I found out that you can avoid some errors by changing the order of your import.
That worked for me but obviously something does not work properly.

Maybe this could become a big problem if there is a program with many lines of code. I can’t image that this error can always be fixed by changing the order of import.

Are there ways to prevent this error?

Someone has a good advice and can help.

Thanks.
Chris

hi chrisTopp:
this is not NVbug,
The error can be fixed by running export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/libgomp.so.1
please try , any problem, feed back ,thanks

It seems that I forgot to say “thank you”.

So with a very big delay thanks a lot for your advice!

This works for me, though once I close the shell window all effect has disappeared. Is it possible to fix this without having to run this command every time?