Cannot detect external monitor - Ubuntu 20.04 + Nvidia GeForce 1660ti

Hi. I am struggling to connect monitor to my laptop with freshly installed ubuntu 20.04
After installation I’ve chosen to install nvidia-driver-440 which was marked as recommended and tested.

nvidia-smi works fine but nvidia-settings produces the following output:

ERROR: Unable to load info from any available system


(nvidia-settings:7086): GLib-GObject-CRITICAL **: 16:40:18.672: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 16:40:18.675: PRIME: No offloading required. Abort
** Message: 16:40:18.675: PRIME: is it supported? no

I have looked into existing topics and tried different things but nothing helped me until now. Need your help.

P.S: I am not sure how connected is it but sound also does not work. One of my sound devices is HDMI device by nvidia. I see only dummy output. I guess it is driver problem.

As for the log I have run nvidia-bug-report but I somehow can’t attach it to the message. Do I need some special permission for that?

just alter the file extension of the log to “.log”

Seems like chromium was the problem. Here it is.

Thanks ahead

nvidia-bug-report.log (339.5 KB)

Please remove the ‘nomodeset’ parameter.

I was afraid that could be a problem. But how can I resolve problem of ubuntu freezing on boot if I remove this option? Does it happen because kernel is loading graphics too early? This is the answer and solution that I’ve found. When I removed it from grub ubuntu started to freeze again. So what’s the correct solution to fix that problem?

Has there been a recent sale of your notebook model?
The problem is, Ubuntu 20.04 has a bug so it won’t work on your
Dell G3 3590
Please install Ubuntu 18.04 which works fine though you will hit sound problems, can be mitigated to a certain degree, see this:
https://forums.developer.nvidia.com/t/ubuntu-20-04-init-i915-and-hdmi-codec-failed/123879/13
that user has the same model with same problems.

1 Like

Yes, I’ve tried to install ubuntu 18.04 today.
The problem there was that it could not detect videocard model in “additional drivers” (in comparison with 20.04), So I will try once again and I will also install custom kernel as you proposed in link you have shared above. I will install ubuntu 18.04 without “nomodeset” and will update whether it helped me to resolve initial problem or not. BTW which version of driver do you recommend to install on 18.04 for this videocard? 440?

As for the sound it looks like it’s a bug without solution for now. So there is probably no way to have both input and output devices until it will be resolved in future versions. Hopefully

Don’t install the 5.6 kernel, that was only a test for the sound problem that didn’t help.
Just install 18.04, then upgrade hwe to latest
https://wiki.ubuntu.com/Kernel/LTSEnablementStack
then do a full system update and afterwards the 440 driver should be available from the Software&Updates application.
Then you can add the sound modules options to get at least the sound working.

1 Like

It worked fine on 18.04 without additional changes.
I have also succeeded to make output work with advices from another thread. So now the only problem is that input is not working. Hopefully it will be fixed in future kernels. Thank you.