Cannot download model from NGC

Please provide the following information when requesting support.

• Hardware GeForce RTX2080Ti (train) / Jetson NX (infer)
• Network Type (Mask_rcnn)
• TAO toolkit_version: 5.0.0
• Training spec file (default as provided with MaskRCNN notebook)
• How to reproduce the issue ? (This is for errors. Please share the command line and the detailed log here.)


I am trying to run the MaskRCNN notebook, and the command to download the pretrained model from NGC runs very slow, and even stops most of the time. Internet connection is stable, and NGC diagnostics show everything is correctly set up.
!ngc registry model download-version nvidia/tao/pretrained_instance_segmentation:resnet50 --dest $LOCAL_EXPERIMENT_DIR/pretrained_resnet50 throws a timeout after 5’:

   Download status: FAILED
   Downloaded local path model: /mnt/NVME_DATA/Training_Sessions/TAO_experiments/tao5_default_2/mask_rcnn/pretrained_resnet50/pretrained_instance_segmentation_vresnet50
   Total files downloaded: 0
   Total transferred: 0 B
   Started at: 2023-09-07 15:55:35
   Completed at: 2023-09-07 16:00:37
   Duration taken: 5m 1s

I have also tried the wget version, with the same result:
wget --content-disposition '' -O resnet50.hdf5

Please, advise how to proceed.

Kind regards,

I can run below two commands successfully.

ngc registry model download-version nvidia/tao/pretrained_instance_segmentation:resnet50


wget --content-disposition ''

Could you please retry or try another machine? Thanks.

Thanks for the quick reply.
I tested it on another local machine and a cloud instance, and it worked fine there.

No idea why it’s so slow on this machine, but I’ll figure it out.