Cannot enable denver cores for TX2 (Jetpack 4.4 DP)


  1. I updated to Jetpack 4.4 DP and then I cannot find the power mode Denver. or, the two denver cores do not work at all.
    ( Observed by tegrastats or jtop )

  2. I need only cuda 10 on my TX2 and I wonder if it works if I install cuda 10.2 (downloaded in Jetpack 4.4) directly in a Jetpack 4.3 environment.



Hi zhuyijun,

Please run below command to enable denver cores:

sudo nvpmodel -m 0

Hi Carolyuu,

Thank you for your help. It seems that the two denver cores are still not working, showing 0%, and the other 4 arm cores took the majority in calculation.

Hi zhuyijun,

What samples are you running?
Please list your tegrastats:

$ sudo tegrastats

I let 4 CPUs fully loaded, mode MAXN :

stress --cpu 4 --timeout 600

and you can see the tegrastats as well as the jtop showing 100%, 0%, 0%, 100%, 100%, 100%

I tried before in a Jetpack 4.3 environment by the same way and it seems that the 2 denver cores take the majority for any calculation :

  1. stressing 1 core: CPU2 = 100% (Denver)
  2. stressing 2 cores: CPU2 & 3 = 100% (Denver)
  3. stressing 3 cores: CPU2 & 3 & 4 = 100% (2 Denver and 1 ARM)
  4. stressing 4 cores: CPU1 & 2 & 3 & 6 = 100% (2 Denver and 2 ARM)

Thus I wonder that the 2 Denver cores are not working.

Thank you,

Hi zhuyijun,

We will check issue and update to you.

Hi zhuyijun,

Please remove isolcpus=1-2" property in config file:
CMDLINE_ADD="console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0;

Please reference Release Notes.

Hi Carolyuu,

Thank you very much.

Would you please tell me more about how to modify this property? I have no idea if I should reflash the board after having changed the files on the host.

Hi zhuyijun,

Please reference below steps:

  1. sudo vim p2771-0000.conf.common
  2. Remove “isolcpus=1-2”:
    CMDLINE_ADD=“console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0”;
  3. Flash kernel-dtb:
    $ sudo ./ -r -k kernel-dtb jetson-tx2 mmcblk0p1

Has this fix changed since the DP? Tried it. Didn’t work.

Hi zhuyijun,

After follow my steps to remove “isolcpus=1-2”, you don’t see the denver cores enable?
The “p2771-0000.conf.common” is in Linux_for_Tegra folder, edit it and remove “isolcpus=1-2”, then flash again.
After system boot up, run “sudo nvpmodel -m 0” to enable denver cores and using “tegrastats” to check.

Yep, I performed those steps. It did not work.

Jetpack 4.4 is so buggy.

Hi zhuyijun,

We’ll check internal and update to you.

I await your assistance.

Hi zhuyijun,

After remove “isolcpus=1-2” from “p2771-0000.conf.common”, please full flash the image:
$ sudo ./ jetson-tx2 mmcblk0p1
Then denver cores working!

I did remove that. I put the tx2 into forced recovery mode. I did the flash. No change.

Hi vondalej,

Are you using full flash command?
We tried it on JP-4.4 GA (r32.4.3), confirmed it’s working!

Is NVIDIA going to fix this?
Is the plan to leave it as it is for all future JetPack releases and force customers to make the described change if they want to run processes on the Denver cores?

Performed the full flash using the command you provided. booted up. Re-setup the computer. Enabled MAXN. No change…

RAM 1133/7859MB (lfb 1485x4MB) SWAP 0/3929MB (cached 0MB) CPU [47%@2035,0%@2035,0%@2035,38%@2035,44%@2035,38%@2035] EMC_FREQ 0% GR3D_FREQ 0% PLL@50C MCPU@50C PMIC@100C Tboard@45C GPU@49.5C BCPU@50C thermal@50.1C Tdiode@48.25C VDD_SYS_GPU 228/228 VDD_SYS_SOC 991/991 VDD_4V0_WIFI 0/0 VDD_IN 5299/5299 VDD_SYS_CPU 1296/1296 VDD_SYS_DDR 1423/1423

I’m getting so fed up with the failures of Jetpack 4.4. Should I just flash 4.3 at this point to stop the insanity?