Cannot enable denver cores for TX2 (Jetpack 4.4 DP)

Has this fix changed since the DP? Tried it. Didn’t work.

Hi zhuyijun,

After follow my steps to remove “isolcpus=1-2”, you don’t see the denver cores enable?
The “p2771-0000.conf.common” is in Linux_for_Tegra folder, edit it and remove “isolcpus=1-2”, then flash again.
After system boot up, run “sudo nvpmodel -m 0” to enable denver cores and using “tegrastats” to check.

Yep, I performed those steps. It did not work.

Jetpack 4.4 is so buggy.

Hi zhuyijun,

We’ll check internal and update to you.

I await your assistance.

Hi zhuyijun,

After remove “isolcpus=1-2” from “p2771-0000.conf.common”, please full flash the image:
$ sudo ./flash.sh jetson-tx2 mmcblk0p1
Then denver cores working!

I did remove that. I put the tx2 into forced recovery mode. I did the flash. No change.

Hi vondalej,

Are you using full flash command?
We tried it on JP-4.4 GA (r32.4.3), confirmed it’s working!

Is NVIDIA going to fix this?
OR
Is the plan to leave it as it is for all future JetPack releases and force customers to make the described change if they want to run processes on the Denver cores?

Performed the full flash using the command you provided. booted up. Re-setup the computer. Enabled MAXN. No change…

RAM 1133/7859MB (lfb 1485x4MB) SWAP 0/3929MB (cached 0MB) CPU [47%@2035,0%@2035,0%@2035,38%@2035,44%@2035,38%@2035] EMC_FREQ 0% GR3D_FREQ 0% PLL@50C MCPU@50C PMIC@100C Tboard@45C GPU@49.5C BCPU@50C thermal@50.1C Tdiode@48.25C VDD_SYS_GPU 228/228 VDD_SYS_SOC 991/991 VDD_4V0_WIFI 0/0 VDD_IN 5299/5299 VDD_SYS_CPU 1296/1296 VDD_SYS_DDR 1423/1423

I’m getting so fed up with the failures of Jetpack 4.4. Should I just flash 4.3 at this point to stop the insanity?

Thank you very much,

I did enabled the two denver cores several months ago after your kind assistance.

We test the performance then, the performance did not take any improvement. The reason maybe that the 4 ARM cores are enough for our algoithm, while the ability of GPU being the limitation. Thus, the additional two denver cores are redundant even though they took the majority of the cpu calculations.

We would try to add more loads on the cpu in order to see if the optimization for cpu scheduling is problematic or it is the power management who limited the performance of the two denver cores.

Finally, thank you for your patience and the Nvidia team supports.

Kind wishes,

ZHU Yijun

Hello all,

Actually, it seems that lots of bugs appeared on the Jetpack 4.4 DP, but I found that the performance of cuda 10 .2 is much better than that on hte Jetpack 4.3. The cusparse became much more faster.

If you have some other caracteristics found to improve the calculation performance, please remind me. Thank you all.

Kind Regards,

ZHU Yijun

It worked for you on the DP, however there were some changes since then that appears to render this fix unusable.

Per the other thread. It appears your fix is temporary and is undone after a normal update.

I know this will be a bit of a pain, but if you get this set up working again, and then go to do an update, perhaps you could log the update. Then, if the problem comes back, there will be a list of packages triggering the issue. For example:

sudo apt update
sudo apt-get upgrade 2>&1 | tee log_upgrade.txt

ok carolyuu. There is something in /etc/apt/sources.list.d/nvidia-l4t-apt-source.list that undoes the “CONFIRMED IT’S WORKING” once updated.

Mark as a bug and notify when fixed.

Hi,
We have confirmed the issue is not seen on Jetpack 4,4 GA with the steps

Not sure but you probably have -r in the flash command. If you have -r, please remove it and try again.

DaneLLL,

I understand you “confirmed” it, however I haven’t seen you respond to the fact that the cores are disabled after an update.

I’m willing to try again, but I need to see that you have done this and an update.

This is what it looks like when I lock /etc/apt/sources.list.d/nvidia-l4t-apt-source.list after your fix. Looks good right?
before

unlock it and do an update. BOOOM. dead cores.
after

This is not fixed and if I see CONFIRMED typed one more time I’m going to throw something through my monitor.

Hi,
Thanks for information. We will execute sudo apt update and check again.