Cannot flash bootloader on Jetson Nano 2GB Devkit

Hi, I am trying to modify the boot logo of Jetson Nano 2GB.
I generated custom-bmp.blob file.
Running the following command is stuck with this message.
I’ve waited more then 30 minutes but it didn’t go to next steps.

tegracm --chip -x21 0 --rcm rcm_list_signed.xml --skipuid

Kindly help me to figure this out!

Can you share steps you did for creating your custom blob file in detail?
Does the generated blob fit the size limit?

Quote from Linux_for_Tegra/tools/bmp-splash/bmp-blob-README.txt:

The size of the bmp.blob shipped with current L4T releases is 70988
bytes. Jetson boards allocate a BMP partition in flash*.xml that is
large enough for that size blob, plus some slack. Limit your blob to three
BMP files at most, and use compression so that it will fit on all boards.

My custom blob file size is 63kB, which is even smaller than the default Nvidia logo blob.
It’s because I used pretty simple white logo on a black background.
I tested it with Jetson Nano 4G RAM + eMMC version.
Using, jetson-nano-emmc as target.

sudo ./ -r -k BMP --image [PATH/TO/IMB-BLOB] jetson-nano-emmc mmcblk0p1

The command only fails on Jetson Nano 2GB module SD card version, using jetson-nano-2gb-devkit target.

Hi, can you attach the blob file you use here?
Let’s see if we can re-produce it on our side.

Yes, I can.
Here’s the blob file and a short doc of how I did it on Jetson Nano 4G eMMC version.

The blob file is used for changing logo for 4G eMMC.
But not working on 2G SD card version.

Hi, I can successfully flashed our Nano 2GB using your logo blob on our side.
Not sure if you flashed your 2GB module with the command directly after flashing the 4GB eMMC module,

sudo ./ -r -k BMP --image [PATH/TO/IMB-BLOB] jetson-nano-2gb-devkit mmcblk0p1

if that was the case, then the -r option would use the system image created for the 4GB eMMC module, which could not work on the 2GB module.

Can you try to replace the blob file in the BSP, and do a whole re-flash?
If it still does not work, try for a different SD card or micro USB cable for flashing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.