Cannot Install nvidia-l4t-jetson-multimedia-api

I’m trying to use Gstreamer with hardware encoding on my TX2 board (Jetpack 4.6.2)

Running gst-inspect-1.0 | grep h264 gives me the following output:

rtp:  rtph264pay: RTP H264 payloader
rtp:  rtph264depay: RTP H264 depayloader
libav:  avdec_h264: libav H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 decoder
libav:  avenc_h264_omx: libav OpenMAX IL H.264 video encoder encoder
typefindfunctions: video/x-h264: h264, x264, 264
videoparsersbad:  h264parse: H.264 parser
uvch264:  uvch264src: UVC H264 Source
uvch264:  uvch264mjpgdemux: UVC H264 MJPG Demuxer

I believe that I need to install nvidia-l4t-jetson-multimedia-api for harware encoding. I have tried to install it using sudo apt-get install nvidia-l4t-jetson-multimedia-api which returns:

Package nvidia-l4t-jetson-multimedia-api is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Trying with sudo apt-get install nvidia-l4t-jetson-multimedia-api* gives:

E: Unable to locate package nvidia-l4t-jetson-multimedia-api_32.7.2-20220420143418_arm64.deb
E: Couldn't find any package by glob 'nvidia-l4t-jetson-multimedia-api_32.7.2-20220420143418_arm64.deb'
E: Couldn't find any package by regex 'nvidia-l4t-jetson-multimedia-api_32.7.2-20220420143418_arm64.deb'

I can find and download the specific package nvidia-l4t-jetson-multimedia-api_32.7.2-20220420143418_arm64.deb from but there’s so many dependency issues that it won’t automatically resolve which makes it very impractical.

Should my TX2 be able to find and automatically install the dependencies from the online repo for me? Any help would be greatly appreciated.

Please try this method and see if it works:
Jetson/L4T/r32.7.x patches -

[32.7.1][apt install] issue in apt install nvidia-jetpack

Hi DaneLLL,

I tried the steps suggested, but when running sudo apt install nvidia-l4t-jetson-multimedia-api=32.7.1-20220219090344 I get the error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nvidia-l4t-jetson-multimedia-api

Is there anything else I need to do to fix this?


Please make sure you have this:

nvidia@nvidia-desktop:~$ cat /etc/apt/sources.list.d/nvidia-l4t-apt-source.list
# SPDX-FileCopyrightText: Copyright (c) 2019-2021 NVIDIA CORPORATION & AFFILIATES. All rights reserved.
# SPDX-License-Identifier: LicenseRef-NvidiaProprietary
# NVIDIA CORPORATION, its affiliates and licensors retain all intellectual
# property and proprietary rights in and to this material, related
# documentation and any modifications thereto. Any use, reproduction,
# disclosure or distribution of this material and related documentation
# without an express license agreement from NVIDIA CORPORATION or
# its affiliates is strictly prohibited.

deb r32.7 main
deb r32.7 main

And then execute sudo apt update

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.