Can't boot into KDE WAYLAND session with 530.30..02

I can also modify the PKGBUILD file to pull and use the older driver. Normally that works just fine since there is no rollback downgrade for that version of the driver that I can see.

Are you talking about the 525.89.02-2 packages from the Arch Archive? They should be there, I see them on archive.archlinux.org. (Ignore this if you’re talking about the AUR ones)

I don’t know why NVIDIA can’t hotfix this if it did indeed work with x.89 driver.
Regressions like this are terrible. This also makes open-source look better by the day because atm, nobody in the community appears to be able to fix this issue.

I’m with you on that. Open-source isn’t perfect and sometimes things take ages to fix, but they’re usually low-priority or affect very few users. Something like this, completely breaking Wayland on all compositors, would almost certainly receive a hotfix within a week, if not days. Already made up my mind that I’m going with AMD for my next GPU.

1 Like

Doesn’t matter, doesn’t work.

They have the same fault, plus to install older nvidia package you also need to roll back kernel version. Basically on top of Plasma not working at high hz, there are additional bugs happening such as DRM not working in older drivers apparently.

I tried the NVIDIA open driver but it doesn’t help and has no drm module. Plus I think its washing out my main displays colours.

UPDATE: Seems nvidia-drm module is just broken now? however I see it loads it automatically so who knows. Must not need that in the boot options anymore.

That’s unfortunate :/

Not sure what the issue here is then. Don’t recall changing anything other than my pacman hook and blacklisting the packages and it just worked, but maybe I’m forgetting something.

@amrits Any updates on this issue?

older nvidia drivers do work on newer kernels, you just need the dkms nvidia package

Also running series 525 (525.116.04 to be exact) and not facing the issue, only on 530

What GPU is that with?

I switched back to some 525 drivers (nvidia-525xx-dkms nvidia-525xx-settings nvidia-525xx-utils to be exact that are sourced from nvidia site) but primary screen over 75hz causes system lockup to blackscreen on login.

Further testing info:
Secondary screen CAN be any HZ from what I can tell provided the primary doesn’t exceed 75hz.
If I run my second screen at 120-144hz and primary at 60hz, no issue.
As soon as I run my primary above 75hz the issue occurs.

Deleting the files in ~/.local/share/kscreen/ resets the configurations back to default 60hz.

Lastly, setting 120hz on my primary WITHIN kwin wayland while logged in does not cause any issues. This bug ONLY occurs at the login/init phase of Plasma/Gnome etc…

I have tested without SDDM login manager and it still occurs so isn’t related to login manager afaik.

Again my card is a RTX 4090 on a AMD 7700x running EndeavourOS/ARCH. I have tested also on Nobara and Artix OS’s and same issue.

This seems to be a real low hanging fruit issue but I’m guessing because very few people have a RTX 40 series card and running it under Linux AND also are developers that might know whats going on, that this issue is going under the radar.

Even GloriousEggroll only has a GTX Laptop to test with.

My card is an RTX 3070 Founders Edition. Maybe you’re facing a different issue? I am running the same drivers as you (I grabbed them from the AUR) and am having no issues. It’s only with the 530 branch that I experience black screen >120hz.

This can’t be a minor issue. The issue occurs on all gpu’s on the 530 drivers from what I can see.

It’s possible the issue also exists in 525 driver for the 40 series only but in 530 driver it happens on more RTX cards.

I do know some people were complaining about 530 producing bad stutters in games (under wayland I think) but there is a different issue.

Just updated to 535 and still experience the unable to boot with 165hz display unfortunately

Can also confirm I am still facing this on 535. This is so stupid

2 Likes

had to go back to 525.116.04 to get 240 hz screen working under wayland.

530.41.03 only goes up to 144 hz with a 3080 ti on gentoo, kde, wayland. I have not tried 535 branch yet

@amrits bumping this as it seems you’ve forgotten about this major issue affecting a good proportion of nvidia linux users. Somehow your team has released new drivers which still haven’t fixed a bug YOU were able to repro. almost 3 months ago. Get your act together

I wish the 525 driver fixed the issue for me but it didn’t last time I tested it (tried multiple times).

Perhaps having dual monitors triggers the issue in the 525 driver, it is only a problem for me on PRIMARY screen so if I set primary to 60hz and secondary to 165hz, wayland boots, but never if I go above 75hz on primary!

The issue is made worse for me as my entire desktop locks up (no tty access, complete system failure) and I must force a reboot!

This issue also occurs for me on Fedora 38, 530.41.03 from rpmfusion, GTX 1080.

This new driver fixed the issue for me: Linux, Solaris, and FreeBSD driver 535.54.03 [production branch release]

2 Likes

Amazing, they’ve fixed it after 2 complete release cycles from 530 to 535 after over 3 months of this issue being reported and about 3 months of the issue being reproduced by Nvidia.

Anyways, glad it’s fixed. Hoping Nvidia changes how they solve issues like these in the future. Don’t wanna be waiting 3 months again for an issue, which I can’t stress enough, was REPRODUCED BY NVIDIA

1 Like

Thanks everyone for sharing the test results.
Apologize for the delayed fix.

2 Likes

@amrits I am still experiencing this issue. I cannot move any of my monitors above 60hz with any 530.x.x or 535.x.x issue.

My hardware:
RTX 3080
2 1440p monitors, one I normally run at 120hz with g-sync
2 4k moniters, one I normally run at 144hz with g-sync

I can still run g-sync but have to have my monitors at 60hz in order to boot. As described above, once booted I can set 120hz/144hz just fine.

Similar to above:

Driver 535.104.05
RTX 3080ti
1 4k monitor at 120 hz via HDMI (Primary)
2 1440p monitors at 60hz via DisplayPort

Changing the main display to anything above 60 hz causes it to fail to boot in. Similar to above I can set the display to 120 hz without issue after boot.

Have similar issue but happening on Fedora KDE 39 running driver 545.23.08 with a 1050ti on Wayland.
No video what so ever, I can’t even boot to SDDM if the DisplayManager setting is set to Wayland.

KDE Plasma 5.27.10
SDDM 0.20.0
Kernel 6.6.8-200.fc39.x86_64 (64-bit)