Can't build the Single Shot Detector (SSD)

When trying to build the SSD from Caffe(which I successfully was able to do on my other machine running a GTX1070). I get the following error message:

test_bbox_util.cpp:279] Check failed: out_bbox.xmax() == 50. (50 vs. 50) 
*** Check failure stack trace: ***
    @       0x7f805c5718  google::LogMessage::Fail()
    @       0x7f805c7614  google::LogMessage::SendToLog()
    @       0x7f805c5290  google::LogMessage::Flush()
    @       0x7f805c7eb4  google::LogMessageFatal::~LogMessageFatal()
    @           0xa24cc0  caffe::CPUBBoxUtilTest_TestOutputBBox_Test::TestBody()
    @           0xed51f4  testing::internal::HandleExceptionsInMethodIfSupported<>()
    @           0xece14c  testing::Test::Run()
    @           0xece288  testing::TestInfo::Run()
    @           0xece394  testing::TestCase::Run()
    @           0xecfdf8  testing::internal::UnitTestImpl::RunAllTests()
    @           0xed010c  testing::UnitTest::Run()
    @           0x92f118  main
    @       0x7f7c0bc8a0  __libc_start_main
Aborted (core dumped)

I believe I am currently running on JetPack 3.0, with Cuda 8.0 installed. Does anyone have an idea about what that causes the error? The code builds without errors when building on my other machine, so I believe it has something to do with the Jetson.

Hi,

SSD can build and run correctly on Jetson.
Please check this comment for more information:
https://devtalk.nvidia.com/default/topic/1005112/jetson-tx1/compiling-ssd-single-shot-detection-on-jetson-tx1/post/5139362/#5139362

Thanks.

Hi again, I got it to work, but when i run the pascal_video.py file I get now the following error:

F1013 10:41:15.623131 20471 cudnn_conv_layer.cpp:53] Check failed: status == CUDNN_STATUS_SUCCESS (4 vs. 0)  CUDNN_STATUS_INTERNAL_ERROR
*** Check failure stack trace: ***
    @       0x7f8eda8718  google::LogMessage::Fail()
    @       0x7f8edaa614  google::LogMessage::SendToLog()
    @       0x7f8eda8290  google::LogMessage::Flush()
    @       0x7f8edaaeb4  google::LogMessageFatal::~LogMessageFatal()
    @       0x7f8f0fc6b8  caffe::CuDNNConvolutionLayer<>::LayerSetUp()
    @       0x7f8f04463c  caffe::Net<>::Init()
    @       0x7f8f0463b4  caffe::Net<>::Net()
    @           0x40ae90  test()
    @           0x409290  main
    @       0x7f8e5528a0  __libc_start_main
Aborted (core dumped)

How do I fix this?

Hi,

TX2 is sm_62. Please remember to add 62 architecture to Makefile.config:

# CUDA architecture setting: going with all of them.
# For CUDA < 6.0, comment the *_50 lines for compatibility.
CUDA_ARCH := -gencode arch=compute_20,code=sm_20 \
		-gencode arch=compute_20,code=sm_21 \
		-gencode arch=compute_30,code=sm_30 \
		-gencode arch=compute_35,code=sm_35 \
		-gencode arch=compute_50,code=sm_50 \
<b>		-gencode arch=compute_62,code=sm_62 \</b>
		-gencode arch=compute_50,code=compute_50

Thanks.

I also have the same problem on TX2, and according to the above method has not been solved, this problem has been bothering me for a long time, I hope to help me solve, thank you

Hi,

Please remember to rebuild the library after updating the configure.
Thanks.