Can't control GTX 1050 Ti Max-Q fan on ThinkPad X1 Extreme laptop

I’m having trouble controlling the GTX 1050 Ti Max-Q fan on my ThinkPad X1 Extreme laptop. The intel CPU and nvidia GPU shape the same heatsinks on this laptop, but there are two fans. The fan on the CPU side can be controlled by /proc/acpi/ibm/fan, but the fan on the GPU side is presumably controlled by nvidia. I’m running Archlinux with 430.14 nvidia drivers and using bumblebee 3.2.1. I added a Option “Coolbits” “4” line to /etc/bumblebee/xorg.conf.nvidia to enable fan speed control, but I don’t see any fan controls in the nvidia settings. Attached is a screenshot, along with nvidia-bug-report.sh output.

In the below, I have nvidia-settings aliased as follows in order for bumblebee to work.

$ type nvidia-settings
nvidia-settings is aliased to `optirun --bridge none /usr/bin/nvidia-settings -c :8 "$@"'

Before I do everything below, I run nvidia-settings to open the settings window and keep it open so that bumblebee keeps the GPU running.

Trying to set the fan speed does not work.

$ nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUTargetFanSpeed=50"

  Attribute 'GPUFanControlState' (K:8[gpu:0]) assigned value 1.

ERROR: Error resolving target specification 'fan:0' (No targets match target specification), specified in assignment '[fan:0]/GPUTargetFanSpeed=50'.

$ nvidia-settings -a "GPUFanControlState=1" -a "GPUTargetFanSpeed=50"

  Attribute 'GPUFanControlState' (K:8[gpu:0]) assigned value 1.

ERROR: Error resolving target specification '' (No targets match target specification), specified in assignment 'GPUTargetFanSpeed=50'.

nvidia-settings does not report any fan speed options.

$ nvidia-settings -q all | grep Fan
  Attribute 'GPUFanControlState' (K:8[gpu:0]): 1.
    'GPUFanControlState' is a boolean attribute; valid values are: 1 (on/true) and 0 (off/false).
    'GPUFanControlState' can use the following target types: GPU.

Here is my xorg file.

$ cat /etc/bumblebee/xorg.conf.nvidia
Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "true"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "true"
    Option "AllowEmptyInitialConfiguration"
    Option "Coolbits" "4"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "DiscreteNVidia"

    Option "Coolbits" "4"
EndSection

nvidia-bug-report.log.gz (1.13 MB)
nvidia-settings.png

The second fan is not controlled by the nvidia driver, please see this:
https://devtalk.nvidia.com/default/topic/1048624/linux/how-to-set-gpu-fan-speed/post/5321818/#5321818

Thanks! I emailed the thinkpad acpi mailing lists.