Can't Debug CUDA Kernels in VS 2015/2017, CUDA 10, Driver 412.16, Laptop w/ Intel & K2100M

Windows 7
lenovo w540 (intel & Quadro k2100m)
Cuda 10 (had same problem with 9, jumped over to Cuda 10)
Driver 412.16 (tried several versions)

So, If I build a sample program, it compiles and build fine, but when trying to run it, I get a message:
‘Frame not in Module’

Get an exception:
Exception thrown at 0x000000007712759E (ntdll.dll) in sample01.exe: 0xC0000005: Access violation writing location 0x0000000000000000.

Call Stack:
ntdll.dll!RtlActivateActivationContextUnsafeFast() Unknown
ntdll.dll!LdrpProcessStaticImports() Unknown
ntdll.dll!LdrpLoadDll() Unknown
ntdll.dll!LdrLoadDll() Unknown

0000000000060299() Unknown

The current stack frame was not found in a loaded module. Source cannot be shown for this location.

Any ideas? I may have to abandon windows and go back to Linux only, but then I cant play when I’m on the road :)

Sadly I am experiencing the same difficulty (win10, quadro m1200, cuda 10, driver 411.31).

Did you ever find a solution (other than abandoning windows :-) ?

Doesn’t sound like it can find your symbolics. Are you building with -g and/or -G ?

Thought about exactly this. -g (host) was enabled already, but -G (device) was not. Sadly, when I enable -G, Nsight no longer breaks on the OutOfRangeLoad exceptions. Problem solved, right ?

Would you happen to have any thoughts on what the issue might be ?

Can you attach the repro code or an exe?

Is there a problem with a GPU kernel?

  • Stack is only NTDLL (CPU code)
  • If debugging a GPU Kernel, NsightVSE Legacy Debugger can help
    ** Try using -lineinfo (instead of -G)
    ** You might have better luck
    *** putting the driver in TCC mode
    *** using the Nsight Next-Gen Debugger (which does CPU and GPU debugging), but that would require a Pascal or later GPU.