Can't Enable HDR 10 on Ubuntu

Hi,

I have a 1070ti on Ubuntu 18.04.02 (5.0.7) with 418.56 drivers. It works fine but i can’t enable 30 bit color depth or HDR 10.

Display setup:

Main monitor: HDR 10 capable 144hz FreeSync2 1440p DisplayPort 1.4 (FreeSync works fine)
Secondary monitor: Not HDR 10 capable 60hz 4k HDMI 2.0

The problem is when i switch to 30 bit color depth both within NVIDIA settings or xorg.conf and restart, then i can’t interact with Ubuntu UI with mouse, my wallpaper is black and only the keyboard is working. It’s working fine on 24 bit color though.

My xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 418.56


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung C27HG7x"
    HorizSync       223.0 - 223.0
    VertRefresh     48.0 - 144.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1070 Ti"
EndSection

Section "Screen"

# Removed Option "nvidiaXineramaInfoOrder" "DFP-1"
# Removed Option "metamodes" "HDMI-0: nvidia-auto-select +3840+0, HDMI-1: nvidia-auto-select +0+0; HDMI-0: 2560x1440_60 +3840+0, HDMI-1: nvidia-auto-select +0+0; HDMI-0: 1920x1080 +3840+0, HDMI-1: nvidia-auto-select +0+0; HDMI-0: 1920x1080_60_0 +3840+0, HDMI-1: nvidia-auto-select +0+0; HDMI-0: 1920x1080_50 +3840+0, HDMI-1: nvidia-auto-select +0+0; HDMI-0: 1920x1080_30 +3840+0, HDMI-1: nvidia-auto-select +0+0; HDMI-0: 1920x1080_25 +3840+0, HDMI-1: nvidia-auto-select +0+0; HDMI-0: 1920x1080_24 +3840+0, HDMI-1: nvidia-auto-select +0+0; HDMI-0: 1680x1050 +3840+0, HDMI-1: nvidia-auto-select +0+0"
# Removed Option "metamodes" "HDMI-1: nvidia-auto-select +0+0, DP-2: nvidia-auto-select +3840+0 {AllowGSYNCCompatible=On}"
# Removed Option "metamodes" "DP-2: nvidia-auto-select +3840+0, HDMI-1: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-5"
    Option         "metamodes" "DP-2: nvidia-auto-select +3840+0 {AllowGSYNCCompatible=On}, HDMI-1: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

This is a long-standing bug in gnome-shell/mutter.
https://bugs.freedesktop.org/show_bug.cgi?id=102396