Can't enable prime sync

On Mint 20 whenever I use the Nvidia driver I have very annoying screen tear when scrolling or moving windows. I tried enabling prime sync to fix it, I typed " xrandr --output eDP-1-1 --set “PRIME Synchronization” 1 " into the console, and it says " unrecognized option ‘1’ ". Does anyone know if there is something I am doing wrong?nvidia-bug-report.log.gz (275.2 KB)

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

1 Like

Alright, I attached it.

Please add the kernel parameter
and reboot.

sudo cat /sys/module/nvidia_drm/parameters/modeset

should return ‘Y’ if done right.

1 Like

It worked, I have no screen tearing now. Thanks a lot, this was really frustrating me.