After updating to 390.25 , Prime Sync stopped working ( GTX 1050 )

I was using it with 384.111 and it worked great however on 390.25 , Prime Sync is not working and tearing is awful.

I was using it with these steps.

sudo xed /etc/modprobe.d/zz-nvidia-modeset.conf

Adding

options nvidia-XXX_drm modeset=1

At that case XXX is 390.

I check if modeset is on with that command

sudo cat /sys/module/nvidia_drm/parameters/modeset

It says ’ Y ’ as yes.

Finding my output with

xrandr

After found it , i added this to system startup

"xrandr --output eDP-1-1 --set 'PRIME Synchronization' '1'"

It was working with these config on 384.11.

When i decided to open a topic about it , i saw this.

https://devtalk.nvidia.com/default/topic/1029916/linux/video-tearing-with-geforce-gtx-1050/

Generix said there:

After reboot, you can check if it's working with

    xrandr --prop |grep Sync


Should return
PRIME Synchronization: 1

It returns as both 0 and 1 to me.

xrandr --prop |grep Sync
	PRIME Synchronization: 0 
	PRIME Synchronization: 1

In case you’re using kernel 4.15, you’ll need the patches mentioned here
https://devtalk.nvidia.com/default/topic/1029625/linux/no-sys-class-drm-card0-entries-on-kernel-4-15/post/5238776/#5238776
or downgrade to kernel 4.14

Note: disconnected connectors always show PRIME Synchronization: 1

Yes , i also upgraded my kernel to 4.15 because i can turn on and off my keyboard leds with 4.15.

So , how can i apply this patch?

I’m on Mint and i get 4.15 kernel via Ukuu , so that shows my level of experience i guess :D

I don’t know if that works, might break the driver. No warranty.

Download the patch, then

cd /usr/src/nvidia-390-390.25/

check if the patch applies doing a dry-run

sudo patch --dry-run -p3 < /<pathto>/<patch>

if no errors occur, apply the patch

sudo patch -p3 < /<pathto>/<patch>

make the kernel modules

sudo make

reboot.

If it fails, reinstall the driver
sudo apt --reinstall install nvidia-390
Edit: you might have to run sudo update-initramfs in case the modules are embedded in initrd.
It’s safer to downgrade to kernel 4.14 and wait for an updated driver, shouldn’t take too long.

Then i’ll take the safe path and downgrade to 4.14.

I hope Nvidia can fix it quickly.