Video Tearing with Geforce GTX 1050

Hello,
I’m running the latest driver (384.11) provided with ubuntu 16.04 with a Geforce GTX 1050.
I get visual artifacts which look like tearing both when I’m watching videos and playing video games.
There is supposed to be a parameter “Force Full Composition Pipeline” in nvidia-settings, but it seems to be disabled (cannot find it …).

This is really annoying because I’m highly sensitive to the video tearing effect… Any help would be really appreciated.

nvidia-bug-report.log.gz (108 KB)

Please run nvidia-bug-report.sh as root and attach the resulting tar.gz file to your post.
See this how to enable Force Full Composition Pipeline
https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Avoid_screen_tearing
If this is an Optimus laptop, you will have to enable Prime sync instead:
To get rid of tearing, use kernel parameter

nvidia-drm.modeset=1

In case of Ubuntu, you might have to add/edit a file in /etc/modprobe.d/ containing

options nvidia_XXX_drm modeset=1

with XXX being the major version of the installed nvidia driver.
After that, run
update-initramfs -u

It’s an Optimus laptop so you’ll just have to set the

options nvidia_XXX_drm modeset=1

with XXX being the major version of the installed nvidia driver.
Use

grep nvidia /etc/modprobe.d/*

to see if there’s already a file with that entry or create a new file.

After that, run

sudo update-initramfs -u

After reboot, you can check if it’s working with

xrandr --prop |grep Sync

Should return
PRIME Synchronization: 1

Perfect, it works, no more tearing ! Thank you very much !
Should I expect performance decrease with Prime Synchronization ?

No performance loss, it just turns on vsync across gpus.

Awesome ! Thanks !

Hello! I have same problem, but my laptop is Dell inspiron 7000. Can you help me please?
Linux mint cinnamon, gtx 1050ti, Driver version 384

Just use the procedure from post #3, it’s the same for Mint and any Optimus laptop.

When I have to set “options nvidia_XXX_drm modeset=1”?

If in terminal… It say “command not found”

And my laptop is not Optimus =-)

It works!!! Thank very much!!!

Ohhh no… It doesn’t work. It just switch to Intel gpu(((
And when Intel gpu switched I can’t use CUDA in Blender 3D and computer slow down a bit…(

You can attach files to existing posts. When hovering the mouse over it, a paperclip icon appears.
How did you install the driver, using ubuntu packages or the .run installer?
Please run nvidia-bug-report.sh as root and attach the resulting tar.gz file to your post.

I install it from ubuntu packages…

nvidia-bug-report.log.gz (107 KB)

In your case use

sudo tee /etc/modprobe.d/99-prime-sync.conf << "options nvidia_384_drm modeset=1"
sudo update-initramfs -u

After reboot, issuing

sudo cat /sys/module/nvidia_drm/parameters/modeset

should return ‘Y’
If not, use

sudo nano /lib/nvidia-384/modprobe.conf

and change

options nvidia_384_drm modeset=0

into

options nvidia_384_drm modeset=1

then run

sudo update-initramfs -u

and reboot. then check

sudo cat /sys/module/nvidia_drm/parameters/modeset

should return
Y

First command didn’t works. So I created file “/etc/modprobe.d/99-prime-sync.conf” including line “options nvidia_384_drm modeset=1”
Other at list… And in the end returned “Y”
But tearing still present((

Please post the output of

xrandr --prop

and attach a new nvidia-bug-report in that condition.

xrandr --prop
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 disconnected (normal left inverted right x axis y axis)
CscMatrix: 65536 0 0 0 0 65536 0 0 0 0 65536 0
BorderDimensions: 4
supported: 4
Border: 0 0 0 0
range: (0, 65535)
SignalFormat: TMDS
supported: TMDS
ConnectorType: HDMI
ConnectorNumber: 2
_ConnectorLocation: 2
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
EDID:
00ffffffffffff0009e5b90600000000
011a010495221378023d78995b549127
224e5300000001010101010101010101
0101010101013c3780de703814403020
360058c21000001a0000000000000000
00000000000000000000000000fe0042
4f452048460a202020202020000000fe
004e5631353646484d2d4e34360a0082
scaling mode: Full aspect
supported: None, Full, Center, Full aspect
Broadcast RGB: Automatic
supported: Automatic, Full, Limited 16:235
audio: auto
supported: force-dvi, off, auto, on
1920x1080 60.01*+ 59.93
1680x1050 59.95 59.88
1600x1024 60.17
1400x1050 59.98
1280x1024 60.02
1440x900 59.89
1280x960 60.00
1360x768 59.80 59.96
1152x864 60.00
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
960x600 60.00
960x540 59.99
800x600 60.00 60.32 56.25
840x525 60.01 59.88
800x512 60.17
700x525 59.98
640x512 60.02
720x450 59.89
640x480 60.00 59.94
680x384 59.80 59.96
576x432 60.06
512x384 60.00
400x300 60.32 56.34
320x240 60.05
DP-1-1 disconnected (normal left inverted right x axis y axis)
Broadcast RGB: Automatic
supported: Automatic, Full, Limited 16:235
audio: auto
supported: force-dvi, off, auto, on

nvidia-bug-report.log.gz (112 KB)

Njajaha, sorry, didn’t look. Mint is still on xorg 1.18, sync only works with 1.19.x. Look to update your graphics stack.