Can't extract optical flow metadata when using nvdsanalytics plugin in the pipeline

I have the following pipeline:

streammux > pgie > nvtracker > nvdsanalytics > nvvidconverter > tiler > nvosd > nveglglessink

I want to add the nvof plugin to use the optical flow data.
when I add the nvof plugin right after the pgie while keeping everything else as is, I get a segmentation fault error when I try to extract the nvof meta data. It only works if I remove the nvdsanalytics plugin from the pipeline.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Have you tried deepstream-nvof-test to see if it can work?

I am using the python bindings. Yes, I have tried the python app “deepstream-opticalflow” and it worked fine. But this app’s pipeline doesn’t contain the nvdsanalytics plugin. The problem happens only when this plugin is in the pipeline (problem is that I can’t extract opticalflow vectors meta-data).

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Can you share a simple repro for us?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.