Can't Install nvidia drivers/ cuda toolkit on ubuntu

Hi Everyone,
I recently got this laptop " ASUS - ROG Zephyrus 15.6" QHD Gaming Laptop - AMD Ryzen 9 - 16GB Memory - NVIDIA GeForce RTX 3070 - 1TB SSD - Eclipse Grey - Eclipse Grey" and I want to use it with ubuntu to do some cuda/ROS development. However I can’t get any ubuntu version to work with an nivida driver (I’ve tried 460, 460-server, and the 465) with ubuntu 18.04, 20.04, and 21.04. I’ve done the nouveau.modeset=0.

Please help, everytime I try to install an nvidia driver, I just get a black screen and I have to apt purge nvidia to get it back to a working state.

Thanks Much,
-Dylan
nvidia-bug-report.log.gz (395.0 KB)

1 Like

This worked for me:

sudo rm /etc/apt/sources.list.d/cuda*
sudo apt remove --autoremove nvidia-cuda-toolkit
sudo apt remove --autoremove nvidia-*
sudo apt update
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-driver-440
sudo apt-key adv --fetch-keys http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pub
sudo bash -c ‘echo “deb http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64 /” > /etc/apt/sources.list.d/cuda.list’
sudo bash -c ‘echo “deb http://developer.download.nvidia.com/compute/machine-learning/repos/ubuntu1804/x86_64 /” > /etc/apt/sources.list.d/cuda_learn.list’
sudo apt update
sudo apt install cuda-10-1
sudo apt install libcudnn7
==> Add the following lines to your ~/.profile file for CUDA 10.1

set PATH for cuda 10.1 installation

if [ -d “/usr/local/cuda-10.1/bin/” ]; then
export PATH=/usr/local/cuda-10.1/bin${PATH:+:${PATH}}
export LD_LIBRARY_PATH=/usr/local/cuda-10.1/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
fi
Reboot your computer.

Check your settings
Check NVIDIA Cuda Compiler with nvcc --version:

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2019 NVIDIA Corporation
Built on Wed_Apr_24_19:10:27_PDT_2019
Cuda compilation tools, release 10.1, V10.1.168
Check libcudnn version /sbin/ldconfig -N -v $(sed ‘s/:/ /’ <<< $LD_LIBRARY_PATH) 2>/dev/null | grep libcudnn:

ubuntu:~$ /sbin/ldconfig -N -v $(sed ‘s/:/ /’ <<< $LD_LIBRARY_PATH) 2>/dev/null | grep libcudnn
libcudnn.so.7 → libcudnn.so.7.5.1
Check NVIDIA driver with nvidia-smi:

GTX1060 6GB in ubuntu 18.04 (should do fine with 20…?)

does not work on older model than that for me (GTX765M):/

Thanks motopaedia, unfortunately this did not work.

The issue is the amd cpu. I got it working using kernel 5.11.13
However, it seems anything will cause the nvidia drivers to just stop working. any update and the nvidia drivers just stop working again.

Hey, I have the same Laptop! I did with the new Ubuntu version 21.04. but I still can’t use my gpu for machine learning, because cuda toolkit is not supported and neither does nvidia docker.

Drivers work well