Can't launch or create a project

I can’t launch or create a project from the workbench. It was working before. My guess is a token expired and the refesh process isn’t triggered?

{"level":"info","time":"2024/02/06 - 09:44:45","status":200,"latency":"70.708µs","client-ip":"127.0.0.1","method":"POST","path":"/v1/credentials","time":"2024-02-06T09:44:45-05:00","message":"GIN-Request"}
{"level":"warn","time":"2024-02-06T09:44:45-05:00","message":"Trying to match with no credentials configured, did you forget to POST credentials to /v1/credentials?"}
{"level":"info","time":"2024/02/06 - 09:44:46","status":200,"latency":"817.042µs","client-ip":"127.0.0.1","method":"POST","path":"/v1/query","time":"2024-02-06T09:44:46-05:00","message":"GIN-Request"}
{"level":"info","time":"2024/02/06 - 09:44:46","status":200,"latency":"484.990625ms","client-ip":"127.0.0.1","method":"POST","path":"/v1/query","time":"2024-02-06T09:44:46-05:00","message":"GIN-Request"}
{"level":"info","time":"2024-02-06T09:45:20-05:00","message":"Processing git status output"}
{"level":"warn","runtimeInfoPath":"/Users/dclark/.nvwb/project-runtime-info/demo2-962412f2fa72cd27c1fbfc359b0f8c5e71e4e15d","time":"2024-02-06T09:45:20-05:00","message":"No git remote operation output files were found."}
{"level":"info","time":"2024-02-06T09:45:20-05:00","message":"Processing git diff output"}
{"level":"info","time":"2024-02-06T09:45:21-05:00","message":"Processing git diff output"}
{"level":"error","command":"/usr/bin/git notes show 0525c5c3bd53b05a057475377320c9e530e78ac0","stdout":"","stderr":"","exitErr":"error: no note found for object 0525c5c3bd53b05a057475377320c9e530e78ac0.\n","error":"exit status 1","time":"2024-02-06T09:45:21-05:00","message":"problem reading git note"}
{"level":"warn","time":"2024-02-06T09:45:21-05:00","message":"No git note found for commit 0525c5c3bd53b05a057475377320c9e530e78ac0"}
{"level":"info","time":"2024-02-06T09:48:08-05:00","message":"Getting labels metadata for image nvidia/ai-workbench/python-basic:1.0.2"}
{"level":"info","time":"2024-02-06T09:48:09-05:00","message":"Getting labels metadata for image nvidia/ai-workbench/python-cuda117:1.0.3"}
{"level":"info","time":"2024-02-06T09:48:10-05:00","message":"Getting labels metadata for image nvidia/ai-workbench/python-cuda120:1.0.3"}
{"level":"info","time":"2024-02-06T09:48:11-05:00","message":"Getting labels metadata for image nvidia/ai-workbench/python-cuda122:1.0.3"}
{"level":"info","time":"2024-02-06T09:48:11-05:00","message":"Getting labels metadata for image nvidia/ai-workbench/pytorch:1.0.2"}
{"level":"info","time":"2024/02/06 - 09:48:12","status":200,"latency":"4.515087708s","client-ip":"127.0.0.1","method":"POST","path":"/v1/query","time":"2024-02-06T09:48:12-05:00","message":"GIN-Request"}

Welcome to AI Workbench, trying to resolve your issue. Yes something has gone wrong with the connection to github. If you check the status of the Github Integrations it should read connected/disconnected. Configuring Integrations in the Desktop Application - NVIDIA Docs

I got an assist from @dean.kleissas on working this out. I think the underlying issue may have been that I’m using the fish shell, which isn’t supported. But we recreated my environment, and things are working now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.